RESOLVED FIXED 34378
[Qt] WinCE buildfix after r52729
https://bugs.webkit.org/show_bug.cgi?id=34378
Summary [Qt] WinCE buildfix after r52729
Patrick R. Gansterer
Reported 2010-01-30 13:31:23 PST
Rename WTF_PLATFORM_*_ENDIAN to WTF_CPU_*_ENDIAN
Attachments
The patch (1.05 KB, patch)
2010-01-30 13:33 PST, Patrick R. Gansterer
ariya.hidayat: review+
The patch (typo fixed) (1.12 KB, patch)
2010-02-01 02:44 PST, Patrick R. Gansterer
no flags
Patrick R. Gansterer
Comment 1 2010-01-30 13:33:45 PST
Created attachment 47774 [details] The patch
Ariya Hidayat
Comment 2 2010-01-31 15:48:26 PST
Comment on attachment 47774 [details] The patch LGTM. Maybe fix that typo (Q_BIG_EDIAN) as well?
Patrick R. Gansterer
Comment 3 2010-02-01 02:44:39 PST
Created attachment 47823 [details] The patch (typo fixed)
Zoltan Herczeg
Comment 4 2010-02-01 04:19:30 PST
The patch looks good to me, although the comment says: We can not determine the endianess at compile time. If this comment is not valid anymore, please remove or modify it. Furthermore, please do not set commit‑queue flags in the future. It should only be enabled after your patch is accepted.
Patrick R. Gansterer
Comment 5 2010-02-01 04:31:11 PST
(In reply to comment #4) > The patch looks good to me, although the comment says: > > We can not determine the endianess at compile time. > > If this comment is not valid anymore, please remove or modify it. Furthermore, > please do not set commit‑queue flags in the future. It should only be enabled > after your patch is accepted. Currently i compile JSC without Qt. Platform.h "dedects" MIDDLE_ENDIAN which is wrong! So i think the comment is valid. I want to change this to the following in a further patch: #if OS(WINCE) # undef WTF_CPU_BIG_ENDIAN # undef WTF_CPU_MIDDLE_ENDIAN # if PLATFORM(QT) # include <QtGlobal> # if Q_BYTE_ORDER == Q_BIG_ENDIAN # define WTF_CPU_BIG_ENDIAN 1 # endif # endif # include <ce_time.h> #endif
Zoltan Herczeg
Comment 6 2010-02-01 06:50:32 PST
> I want to change this to the following in a further patch: Fixing fixes is not really a WebKit style. Please do this change in patch.
Patrick R. Gansterer
Comment 7 2010-02-01 06:55:52 PST
(In reply to comment #6) > > I want to change this to the following in a further patch: > > Fixing fixes is not really a WebKit style. Please do this change in patch. What should i do now? Changing WTF_PLATFORM_*_ENDIAN to WTF_CPU_*_ENDIAN is _only_ a buildfix. Should i change it to comment #5 or should i change the whole ARM ENDIAN DEDECTION (add ugly OS(WINCE))?
WebKit Commit Bot
Comment 8 2010-02-01 16:39:37 PST
Comment on attachment 47823 [details] The patch (typo fixed) Clearing flags on attachment: 47823 Committed r54176: <http://trac.webkit.org/changeset/54176>
WebKit Commit Bot
Comment 9 2010-02-01 16:39:42 PST
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.