Bug 34336 - REGRESSION: run-webkit-httpd doesn't print requests to stdout
Summary: REGRESSION: run-webkit-httpd doesn't print requests to stdout
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh All
: P1 Normal
Assignee: Andras Becsi
URL:
Keywords:
Depends on:
Blocks: 33153
  Show dependency treegraph
 
Reported: 2010-01-29 10:17 PST by Alexey Proskuryakov
Modified: 2010-02-01 16:08 PST (History)
2 users (show)

See Also:


Attachments
Print requests to stdout if run-webkit-httpd is used (1.76 KB, patch)
2010-01-29 14:21 PST, Andras Becsi
no flags Details | Formatted Diff | Diff
simlified patch (1.28 KB, patch)
2010-01-29 15:40 PST, Andras Becsi
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2010-01-29 10:17:43 PST
run-webkit-httpd used to print responses to console. That's why it runs Apache in single process mode.

It's a serious problem that you can't see what happens on Apache side when working on regression tests.
Comment 1 Andras Becsi 2010-01-29 14:21:27 PST
Created attachment 47734 [details]
Print requests to stdout if run-webkit-httpd is used
Comment 2 Alexey Proskuryakov 2010-01-29 15:03:25 PST
Comment on attachment 47734 [details]
Print requests to stdout if run-webkit-httpd is used

It may be more elegant to just use ">&1" as the first argument to open2(). What do you think?
Comment 3 Andras Becsi 2010-01-29 15:40:03 PST
Created attachment 47739 [details]
simlified patch
Comment 4 WebKit Commit Bot 2010-01-29 15:43:09 PST
Comment on attachment 47739 [details]
simlified patch

Rejecting patch 47739 from commit-queue.

abecsi@webkit.org does not have committer permissions according to http://trac.webkit.org/browser/trunk/WebKitTools/Scripts/webkitpy/committers.py.

- If you do not have committer rights please read http://webkit.org/coding/contributing.html for instructions on how to use bugzilla flags.

- If you have committer rights please correct the error in WebKitTools/Scripts/webkitpy/committers.py by adding yourself to the file (no review needed).  Due to bug 30084 the commit-queue will require a restart after your change.  Please contact eseidel@chromium.org to request a commit-queue restart.  After restart the commit-queue will correctly respect your committer rights.
Comment 5 Alexey Proskuryakov 2010-01-29 15:54:12 PST
Comment on attachment 47739 [details]
simlified patch

Looks good. Please don't remove "close HTTPDIN" - I don't think it's a big deal, but changing this aspect of the code is probably not appropriate for this patch.
Comment 6 Andras Becsi 2010-01-29 16:01:37 PST
Comment on attachment 47739 [details]
simlified patch

Patch committed in revision 54084.
Comment 7 Andras Becsi 2010-01-29 16:31:15 PST
Patch has been landed.  Closing bug.
Comment 8 Eric Seidel (no email) 2010-02-01 13:29:23 PST
the commit-queue has been restarted and will now recognize Andras as a committer.
Comment 9 Andras Becsi 2010-02-01 16:08:53 PST
(In reply to comment #8)
> the commit-queue has been restarted and will now recognize Andras as a
> committer.

Thanks, Eric.