Bug 33816 - Crashes in Geolocation code due to refcounting, observer balance issues
Summary: Crashes in Geolocation code due to refcounting, observer balance issues
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Steve Falkenburg
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-18 16:52 PST by Steve Falkenburg
Modified: 2010-01-22 14:07 PST (History)
0 users

See Also:


Attachments
Patch (2.90 KB, patch)
2010-01-18 16:55 PST, Steve Falkenburg
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Falkenburg 2010-01-18 16:52:32 PST
Geolocation is crashing for me during development. Issues are caused by a reference to a disposed this ptr in GeoNotifier, and an add/remove observer balance issue in GeolocationController.
Comment 1 Steve Falkenburg 2010-01-18 16:55:48 PST
Created attachment 46864 [details]
Patch
Comment 2 Steve Falkenburg 2010-01-22 14:07:41 PST
This is fixed.