Bug 33746 - [GTK] More crashes related to the clipboard management
Summary: [GTK] More crashes related to the clipboard management
Status: RESOLVED DUPLICATE of bug 32900
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks:
 
Reported: 2010-01-15 15:06 PST by Gustavo Noronha (kov)
Modified: 2010-01-21 00:30 PST (History)
0 users

See Also:


Attachments
Use WebView object instead of page for clipboard callbacks, allowing us to avoid its destruction inbetween (4.71 KB, patch)
2010-01-15 15:10 PST, Gustavo Noronha (kov)
gns: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gustavo Noronha (kov) 2010-01-15 15:06:12 PST
OK, looks like my last patch was not enough. I still got some crashes, and end up figuring we cannot trust in Page being alive or null, at all, so my alternative approach to the crash is to do explicit ref counting to guard the webView in between the clipboard call and its callbacks being called.
Comment 1 Gustavo Noronha (kov) 2010-01-15 15:10:29 PST
Created attachment 46713 [details]
Use WebView object instead of page for clipboard callbacks, allowing us to avoid its destruction inbetween
Comment 2 Gustavo Noronha (kov) 2010-01-16 16:25:08 PST

*** This bug has been marked as a duplicate of bug 32900 ***
Comment 3 Maciej Stachowiak 2010-01-21 00:30:07 PST
Comment on attachment 46713 [details]
Use WebView object instead of page for clipboard callbacks, allowing us to avoid its destruction inbetween

Unflagging since this appears to be already fixed in the original of which this is a duplicate.