Bug 33693 - [Qt] Defective dependencies caused build failing on QtBuildBot
Summary: [Qt] Defective dependencies caused build failing on QtBuildBot
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P3 Normal
Assignee: Nobody
URL:
Keywords: Qt
Depends on:
Blocks:
 
Reported: 2010-01-14 15:22 PST by Csaba Osztrogonác
Modified: 2010-01-14 22:15 PST (History)
4 users (show)

See Also:


Attachments
proposed fix (793 bytes, patch)
2010-01-14 15:26 PST, Csaba Osztrogonác
eric: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2010-01-14 15:22:37 PST
Build failed on QtBuildbot yesterday: http://build.webkit.org/builders/Qt%20Linux%20Release/builds/5945
(Clean WebKitBuild/JavaScriptCore directory manually resolved the problem)

error message:
...
obj/release/jsc.o:jsc.cpp:(.text+0x1e36): more undefined references to `JSC::UStringImpl::destroy()' follow
collect2: ld returned 1 exit status
...

JSC::UStringImpl::destroy() removed by http://trac.webkit.org/changeset/53221 ,
but jsc.o and Debugger.o wasn't rebuild mistakenly. It caused by defective 
dependencies for jsc.o and Debugger.o.

Debugger.cpp -> interpreter/Interpreter.h -> runtime/JSCell.h -> runtime/Structure.h -> runtime/Identifier.h -> JsGlobalData.h -> NumericStrings.h -> UString.h -> UStringImpl.h
Debugger.o depends on UStringImpl.h, but this dependency was missing from the Makefile,
because CONFIG variable of jsc.pro doesn't contain depend_includepath.
Comment 1 Csaba Osztrogonác 2010-01-14 15:26:35 PST
Created attachment 46613 [details]
proposed fix

I suggest we add CONFIG += depend_includepath to WebKit.pri,
because all complex pro files include it.
Comment 2 Eric Seidel (no email) 2010-01-14 17:18:33 PST
Comment on attachment 46613 [details]
proposed fix

OK.  I trust you.
Comment 3 Csaba Osztrogonác 2010-01-14 22:15:13 PST
(In reply to comment #2)
> (From update of attachment 46613 [details])
> OK.  I trust you.

Thx, landed in 53319.