Bug 33663 - check-webkit-style underscore check should be disabled for Qt methods starting with qt_
: check-webkit-style underscore check should be disabled for Qt methods startin...
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Tools / Tests
: 528+ (Nightly build)
: PC All
: P3 Normal
Assigned To: Nobody
: Qt
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-14 02:57 PST by Kenneth Rohde Christiansen
Modified: 2010-01-17 18:06 PST (History)
7 users (show)

See Also:


Attachments
Patch (2.43 KB, patch)
2010-01-17 15:46 PST, Adam Barth
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Rohde Christiansen 2010-01-14 02:57:39 PST
check-webkit-style underscore check should be disabled for Qt methods starting with qt_, as Qt uses that for private API, such as for the DRT only.
Comment 1 Eric Seidel 2010-01-14 03:09:06 PST
We could even restrict this allowance to the qt directory, although allowing qt_ anywhere is really not a problem either.
Comment 2 Kenneth Rohde Christiansen 2010-01-14 03:32:08 PST
I would still like the underscore check so make sure that the patches we receive do not use names like _privateMessage() etc.
Comment 3 Adam Barth 2010-01-17 15:46:45 PST
Created attachment 46763 [details]
Patch
Comment 4 Adam Barth 2010-01-17 16:06:41 PST
*** Bug 33116 has been marked as a duplicate of this bug. ***
Comment 5 Shinichiro Hamaji 2010-01-17 17:35:09 PST
Comment on attachment 46763 [details]
Patch

Thanks for fixing this issue!
Comment 6 WebKit Commit Bot 2010-01-17 18:06:16 PST
Comment on attachment 46763 [details]
Patch

Clearing flags on attachment: 46763

Committed r53381: <http://trac.webkit.org/changeset/53381>
Comment 7 WebKit Commit Bot 2010-01-17 18:06:25 PST
All reviewed patches have been landed.  Closing bug.