Bug 33638 - REGRESSION(53133): commit-queue no longer rejects patches with invalid committers, instead it hangs
Summary: REGRESSION(53133): commit-queue no longer rejects patches with invalid commit...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-13 16:32 PST by Eric Seidel (no email)
Modified: 2010-01-14 16:50 PST (History)
1 user (show)

See Also:


Attachments
Patch (17.88 KB, patch)
2010-01-14 16:14 PST, Eric Seidel (no email)
abarth: review+
abarth: commit-queue+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2010-01-13 16:32:44 PST
REGRESSION(53133): commit-queue no longer rejects patches with invalid committers

it simply ignores them.  It logs a message to the commit-queue logs, but doesn't actually update the bug to say it was rejected.  I expect this came of my Attachment refactoring:
http://trac.webkit.org/changeset/53133
Comment 1 Eric Seidel (no email) 2010-01-14 01:53:29 PST
This is worse than expected.  I think that this causes the commit queue to spin.  It doesn't process the patch and I think that it ends up "thinking" that it's empty and waiting another 5 minutes after the failed processing instead of correcting rejecting the patch from the queue and moving on.

So right now someone setting an commit-queue or review flag w/o having proper permissionss looks like it will HANG the queue!  I think the commit-queue was delayed for a day due to this bug!
Comment 2 Eric Seidel (no email) 2010-01-14 13:58:02 PST
I'm working on a fix now.
Comment 3 Eric Seidel (no email) 2010-01-14 16:14:26 PST
Created attachment 46618 [details]
Patch
Comment 4 Eric Seidel (no email) 2010-01-14 16:16:01 PST
I fixed the bug, and then realizing that I had to pile yet another hack into MockBugzillaTool, so I ended up fixing MockBugzillaTool too use a more dynamic system for handling mock bugs and attachments.
Comment 5 Adam Barth 2010-01-14 16:19:52 PST
Comment on attachment 46618 [details]
Patch

Nice and epic!
Comment 6 Eric Seidel (no email) 2010-01-14 16:50:46 PST
Committed r53298: <http://trac.webkit.org/changeset/53298>