> 1. I don't think "InjectedScript", which is a fairly general phrase, is a good
> name to give to this technology. I'd prefer a name that conveyed the fact that
> this technology is only safe to use in limited circumstances. How about
> "InspectorHost" (inside the inspected page) and "InspectorClient" (the Web
> Inspector UI).
I agree with you that the naming is not the best. Currently the inspector
front-end delegate is called InjectedScriptHost. We should come up with
something more specific.