Bug 33559 - [10.6] Font-weight bolder/lighter failures with Helvetica Neue.
Summary: [10.6] Font-weight bolder/lighter failures with Helvetica Neue.
Status: RESOLVED DUPLICATE of bug 18323
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-12 16:36 PST by Philippe Wittenbergh
Modified: 2010-01-13 10:12 PST (History)
1 user (show)

See Also:


Attachments
test case (751 bytes, text/html)
2010-01-12 16:38 PST, Philippe Wittenbergh
no flags Details
screen shot (116.30 KB, image/png)
2010-01-12 16:40 PST, Philippe Wittenbergh
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Wittenbergh 2010-01-12 16:36:37 PST
Safari/WebKit running on 10.6 fails to use some font-weights when specifying font-weight lighter/bolder. The 'Medium' and 'Ultra Light' faces are particularly affected.
The cascade displays correctly on Gecko based browsers.

Testcase: cascade: nested font-weight bolder/lighter.

Actual results: the last two lines display with the same face
Expected results: the last two lines display with different faces

----
In bug 6484 comment 31 a little hack was introduced to work around a 10.5 bug with the same font (<rdar://problem/5781372>). It is coming back to bite ?
https://bugs.webkit.org/show_bug.cgi?id=6484#c31
Comment 1 Philippe Wittenbergh 2010-01-12 16:38:05 PST
Created attachment 46409 [details]
test case
Comment 2 Philippe Wittenbergh 2010-01-12 16:40:43 PST
Created attachment 46410 [details]
screen shot

Screenshot, WebKit latest on the left, Minefield latest nightly on the right (Firefox 3.0.x, 3.5.x and 3.6rc display the same).
Comment 3 mitz 2010-01-12 17:12:07 PST
Is this a duplicate of bug 18323?
Comment 4 Philippe Wittenbergh 2010-01-12 17:17:46 PST
(In reply to comment #3)
> Is this a duplicate of bug 18323?

I'm not sure; iirc, this was working much better on 10.5.8. I can't verify that at the moment, though.
Comment 5 mitz 2010-01-13 10:12:40 PST
(In reply to comment #4)
> (In reply to comment #3)
> > Is this a duplicate of bug 18323?
> 
> I'm not sure; iirc, this was working much better on 10.5.8. I can't verify that
> at the moment, though.

It looks the same in Safari 4.0.4 on Mac OS X 10.5.8.

*** This bug has been marked as a duplicate of bug 18323 ***