Bug 33488 - REGRESSION: webkit-patch upload errors if lacking a ChangeLog
Summary: REGRESSION: webkit-patch upload errors if lacking a ChangeLog
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-11 13:34 PST by Ojan Vafai
Modified: 2010-01-12 04:47 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ojan Vafai 2010-01-11 13:34:16 PST
webkit-patch land now fails with an error if you haven't created a ChangeLog file first. I think it's the linter complaining. This worked as of Friday.
Comment 1 Eric Seidel (no email) 2010-01-11 13:45:23 PST
Land?  Do you mean upload?  "land" doesn't create ChangeLogs that I know of.
Comment 2 Eric Seidel (no email) 2010-01-11 13:46:10 PST
Land has no ChangeLog creation:
http://trac.webkit.org/browser/trunk/WebKitTools/Scripts/webkitpy/commands/download.py#L70
Comment 3 Ojan Vafai 2010-01-11 13:56:48 PST
Doh. Yes, I meant upload.
Comment 4 Ojan Vafai 2010-01-11 13:58:04 PST
backtrace:

ojanmacpro:WebKit ojan$ webkit-patch upload
Traceback (most recent call last):
  File "/WebKit/WebKitTools/Scripts/webkit-patch", line 108, in <module>
    WebKitPatch().main()
  File "/WebKit/WebKitTools/Scripts/webkitpy/multicommandtool.py", line 299, in main
    return command.check_arguments_and_execute(options, args, self)
  File "/WebKit/WebKitTools/Scripts/webkitpy/multicommandtool.py", line 113, in check_arguments_and_execute
    return self.execute(options, args, tool) or 0
  File "/WebKit/WebKitTools/Scripts/webkitpy/commands/abstractsequencedcommand.py", line 43, in execute
    self._sequence.run_and_handle_errors(tool, options, self._prepare_state(options, args, tool))
  File "/WebKit/WebKitTools/Scripts/webkitpy/commands/upload.py", line 162, in _prepare_state
    state = { "bug_id" : self._bug_id(args, tool) }
  File "/WebKit/WebKitTools/Scripts/webkitpy/commands/abstractdiffcommand.py", line 38, in _bug_id
    bug_id = parse_bug_id(tool.scm().commit_message_for_this_commit().message())
  File "/WebKit/WebKitTools/Scripts/webkitpy/scm.py", line 172, in commit_message_for_this_commit
    raise ScriptError(message="Found no modified ChangeLogs, cannot create a commit message.\n"
webkitpy.executive.ScriptError: Found no modified ChangeLogs, cannot create a commit message.
All changes require a ChangeLog.  See:
http://webkit.org/coding/contributing.html
Comment 5 Eric Seidel (no email) 2010-01-11 14:03:20 PST
Sounds like a step ordering problem. :(

http://trac.webkit.org/browser/trunk/WebKitTools/Scripts/webkitpy/commands/upload.py#L138

Looks like the solution is to just move the check-style check until after the ChangeLog prep.  Or to run it before changelog prep with some sort of --ignore-ChangeLogs flag.
Comment 6 Adam Barth 2010-01-11 15:15:28 PST
Crap.  I probably broke this with the bug number patch.  Feel free to roll that out.
Comment 7 Eric Seidel (no email) 2010-01-11 16:08:34 PST
Bug 33197 was reverted in http://trac.webkit.org/changeset/53105.  Adam believes that should fix this regression.
Comment 8 Eric Seidel (no email) 2010-01-12 04:47:58 PST
Closing.  Works for me now.  If this is still giving you trouble Ojan, let us know!