Bug 33471 - webkit-patch rollout mistakenly picks up bug URLs in non-ChangeLog files
Summary: webkit-patch rollout mistakenly picks up bug URLs in non-ChangeLog files
Status: RESOLVED DUPLICATE of bug 36477
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-11 08:53 PST by Adam Barth
Modified: 2010-04-02 00:21 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Barth 2010-01-11 08:53:53 PST
def _parse_bug_id_from_revision_diff(tool, revision):
        original_diff = tool.scm().diff_for_revision(revision)
        # FIXME: This is wrong because it picks up bug numbers outside of ChangeLogs
        return parse_bug_id(original_diff)
Comment 1 Eric Seidel (no email) 2010-04-01 23:22:34 PDT
I believe this is fixed now.
Comment 2 Eric Seidel (no email) 2010-04-02 00:21:56 PDT

*** This bug has been marked as a duplicate of bug 36477 ***