RESOLVED FIXED 33353
[GTK] loading test should use SoupServer instead of actual sites
https://bugs.webkit.org/show_bug.cgi?id=33353
Summary [GTK] loading test should use SoupServer instead of actual sites
Gustavo Noronha (kov)
Reported 2010-01-07 16:32:13 PST
Summary says it all. The test should not require loading stuff from the Internet.
Attachments
proposed patch (11.15 KB, patch)
2010-01-07 16:38 PST, Gustavo Noronha (kov)
xan.lopez: review+
Gustavo Noronha (kov)
Comment 1 2010-01-07 16:38:11 PST
Created attachment 46097 [details] proposed patch
WebKit Review Bot
Comment 2 2010-01-07 16:42:30 PST
Attachment 46097 [details] did not pass style-queue: Failed to run "WebKitTools/Scripts/check-webkit-style" exit_code: 1 WebKit/gtk/tests/testloading.c:32: Declaration has space between * and variable name in SoupURI* base_uri [whitespace/declaration] [3] WebKit/gtk/tests/testloading.c:32: base_uri is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKit/gtk/tests/testloading.c:91: get_uri_for_path is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKit/gtk/tests/testloading.c:93: Declaration has space between * and variable name in SoupURI* uri [whitespace/declaration] [3] WebKit/gtk/tests/testloading.c:94: Declaration has space between * and variable name in char* uri_string [whitespace/declaration] [3] WebKit/gtk/tests/testloading.c:94: uri_string is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKit/gtk/tests/testloading.c:98: Extra space before ( in function call [whitespace/parens] [4] WebKit/gtk/tests/testloading.c:148: Declaration has space between * and variable name in char* uri_string [whitespace/declaration] [3] WebKit/gtk/tests/testloading.c:148: uri_string is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKit/gtk/tests/testloading.c:208: Declaration has space between * and variable name in char* uri_string [whitespace/declaration] [3] WebKit/gtk/tests/testloading.c:208: uri_string is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKit/gtk/tests/testloading.c:271: Declaration has space between * and variable name in char* uri_string [whitespace/declaration] [3] WebKit/gtk/tests/testloading.c:271: uri_string is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKit/gtk/tests/testloading.c:315: Declaration has space between * and variable name in char* uri_string [whitespace/declaration] [3] WebKit/gtk/tests/testloading.c:315: uri_string is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKit/gtk/tests/testloading.c:316: Declaration has space between * and variable name in char* uri_string2 [whitespace/declaration] [3] WebKit/gtk/tests/testloading.c:316: uri_string2 is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKit/gtk/tests/testloading.c:343: load_error_test is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKit/gtk/tests/testloading.c:350: Declaration has space between * and variable name in char* uri_string [whitespace/declaration] [3] WebKit/gtk/tests/testloading.c:350: uri_string is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] WebKit/gtk/tests/testloading.c:394: Declaration has space between * and variable name in SoupServer* server [whitespace/declaration] [3] Total errors found: 21
Xan Lopez
Comment 3 2010-01-08 03:02:24 PST
Comment on attachment 46097 [details] proposed patch >+/* For real request testing */ >+static void >+server_callback(SoupServer *server, SoupMessage *msg, >+ const char *path, GHashTable *query, >+ SoupClientContext *context, gpointer data) This style issue you should fix at least. BTW, I'm not sure I see any valid reason to not use the WebKit style in our tests too. Not in this patch, but we should do it afterwards. Everything else looks good to me, thanks for working on this.
Gustavo Noronha (kov)
Comment 4 2010-01-08 03:49:41 PST
(In reply to comment #3) > (From update of attachment 46097 [details]) > >+/* For real request testing */ > >+static void > >+server_callback(SoupServer *server, SoupMessage *msg, > >+ const char *path, GHashTable *query, > >+ SoupClientContext *context, gpointer data) > > This style issue you should fix at least. > > BTW, I'm not sure I see any valid reason to not use the WebKit style in our > tests too. Not in this patch, but we should do it afterwards. > > Everything else looks good to me, thanks for working on this. True. I guess it just started like this. I can move them to webkit style.
Gustavo Noronha (kov)
Comment 5 2010-01-08 03:57:30 PST
Landed as r52986.
Note You need to log in before you can comment on or make changes to this bug.