Bug 33328 - Radio buttons do not fire "onchange" when operated via the keyboard
Summary: Radio buttons do not fire "onchange" when operated via the keyboard
Status: RESOLVED DUPLICATE of bug 32013
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Critical
Assignee: Nobody
URL: http://fluidproject.org/releases/1.1....
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-07 10:11 PST by Antranig Basman
Modified: 2010-01-07 10:45 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antranig Basman 2010-01-07 10:11:09 PST
Navigate to the page in the URL, and press the "Render" button in the demo. Then navigate to the radio buttons governing selection of "Wines" using TAB, and use the arrow cursor keys to update the selection. No "onchange" event is received for this control, as shown by the failure of the update in the right-hand pane. Operate the radio buttons using the mouse - the "wineList: choice:" entry will update indicating that onchange is received. This demo works in every recent browser which is not based on WebKit of 528+ (IE 6+/Firefox 2+/Opera 9+). This has been tested on the latest Safari release on Mac and Windows, as well as on the latest Webkit nightly (at time of writing, r52746 of SVN). At the moment, the only workaround is to manually detect the delivered event via "onkeyup". This issue is a significant impediment to delivery of accessible applications on the WebKit platform.
Comment 1 Alexey Proskuryakov 2010-01-07 10:45:15 PST

*** This bug has been marked as a duplicate of bug 32013 ***