Bug 33302 - [Qt] Install NPAPI headers as part of QtWebKit public APIs
Summary: [Qt] Install NPAPI headers as part of QtWebKit public APIs
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Nobody
URL:
Keywords: Qt
Depends on:
Blocks:
 
Reported: 2010-01-06 21:30 PST by Laszlo Gombos
Modified: 2010-01-07 17:55 PST (History)
3 users (show)

See Also:


Attachments
proposed patch (1.29 KB, patch)
2010-01-06 21:41 PST, Laszlo Gombos
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Laszlo Gombos 2010-01-06 21:30:10 PST
The driver for this is to give a chance for plugin developers to make sure that they have access to the exact version of NPAPI interfaces that was used to build QtWebKit.
Comment 1 Laszlo Gombos 2010-01-06 21:41:54 PST
Created attachment 46020 [details]
proposed patch
Comment 2 WebKit Review Bot 2010-01-06 21:44:58 PST
style-queue ran check-webkit-style on attachment 46020 [details] without any errors.
Comment 3 Laszlo Gombos 2010-01-07 06:27:34 PST
Comment on attachment 46020 [details]
proposed patch

cancel review, need more info for the motivation.
Comment 4 Laszlo Gombos 2010-01-07 17:55:41 PST
These header files are not part of Qt and we should not redistribute them.