Bug 33271 - Number of repaint tests need new pixel results due to r52839
Summary: Number of repaint tests need new pixel results due to r52839
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-06 14:44 PST by James Robinson
Modified: 2010-01-10 20:41 PST (History)
3 users (show)

See Also:


Attachments
Patch (263.28 KB, patch)
2010-01-06 14:50 PST, James Robinson
no flags Details | Formatted Diff | Diff
Patch (262.56 KB, patch)
2010-01-06 14:59 PST, James Robinson
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James Robinson 2010-01-06 14:44:01 PST
http://trac.webkit.org/changeset/52839 caused a number of fast/repaint tests to progress (by repainting a smaller amount of the screen).  They need new pixel results.
Comment 1 James Robinson 2010-01-06 14:50:23 PST
Created attachment 45997 [details]
Patch
Comment 2 WebKit Review Bot 2010-01-06 14:52:32 PST
style-queue ran check-webkit-style on attachment 45997 [details] without any errors.
Comment 3 mitz 2010-01-06 14:53:05 PST
Comment on attachment 45997 [details]
Patch

> Index: WebKitTools/Scripts/webkitpy/credentials.py
> ===================================================================
> --- WebKitTools/Scripts/webkitpy/credentials.py	(revision 52868)
> +++ WebKitTools/Scripts/webkitpy/credentials.py	(working copy)
> @@ -96,8 +96,8 @@ class Credentials(object):
>          if Git.in_working_directory(self.cwd):
>              (username, password) = self._credentials_from_git()
>  
> -        if not username or not password:
> -            (username, password) = self._credentials_from_keychain(username)
> +#        if not username or not password:
> +#            (username, password) = self._credentials_from_keychain(username)
>  
>          if not username:
>              username = raw_input("%s login: " % self.host)

This looks irrelevant.
Comment 4 James Robinson 2010-01-06 14:56:06 PST
Will fix the python noise.

For whoever reviews this:

fast/repaint/background-misaligned.html and
fast/repaint/float-in-new-block-with-layout-delta.html appear to be avoiding an
extra full screen repaint pass, but I'm not entirely sure I am interpreting the
results correctly.

fast/repaint/selected-replaced.html looks like r52839 actually introduced a
slight regression - a few pixels at the bottom of the white area to the right
of the apple appear to be painting an extra time.  It's very small.

The rest of the tests are clear progressions.
Comment 5 James Robinson 2010-01-06 14:59:03 PST
Created attachment 45998 [details]
Patch
Comment 6 WebKit Review Bot 2010-01-06 15:03:21 PST
style-queue ran check-webkit-style on attachment 45998 [details] without any errors.
Comment 7 Eric Seidel (no email) 2010-01-07 17:29:45 PST
Comment on attachment 45998 [details]
Patch

Please file a bug about any regressions.
Comment 8 WebKit Commit Bot 2010-01-10 19:52:02 PST
Comment on attachment 45998 [details]
Patch

Rejecting patch 45998 from commit-queue.

Failed to run "['/Users/eseidel/Projects/CommitQueue/WebKitTools/Scripts/svn-apply', '--reviewer', 'Eric Seidel', '--force']" exit_code: 1
Last 500 characters of output:
cksum.rej
patching file LayoutTests/platform/mac/fast/repaint/selected-replaced-expected.checksum
Hunk #1 FAILED at 1.
1 out of 1 hunk FAILED -- saving rejects to file LayoutTests/platform/mac/fast/repaint/selected-replaced-expected.checksum.rej
patching file LayoutTests/platform/mac/fast/repaint/transform-replaced-shadows-expected.checksum
Hunk #1 FAILED at 1.
1 out of 1 hunk FAILED -- saving rejects to file LayoutTests/platform/mac/fast/repaint/transform-replaced-shadows-expected.checksum.rej

Full output: http://webkit-commit-queue.appspot.com/results/178462
Comment 9 James Robinson 2010-01-10 20:40:09 PST
Comment on attachment 45998 [details]
Patch

http://trac.webkit.org/changeset/53010
Comment 10 Eric Seidel (no email) 2010-01-10 20:40:56 PST
Can this bug be closed?
Comment 11 James Robinson 2010-01-10 20:41:51 PST
Fixed.  (still getting used to bugzilla)