logging.py should be renamed to webkit_logging.py and eventually die
Turns out that python has a built in logging system. Who knew? This python n00b didn't. :)
Anyway, logging.py has the same import name as python's built in logging, so it needs to be renamed if we want to use python's logging. Eventually our logging module (once renamed to webkit_logging.py) should die.
I'm not sure why I created a bug. Review of this kind of patch isn't very useful. But I guess I'll post it anyway.
Created attachment 45672 [details]
Comment on attachment 45672 [details]
Ok. We have a bunch of these kinds of patches to do.
Committed r52667: <http://trac.webkit.org/changeset/52667>