Bug 3300 - XSLT parser ignores document DTD
: XSLT parser ignores document DTD
Status: RESOLVED DUPLICATE of bug 7184
Product: WebKit
Classification: Unclassified
Component: XML
: 412
: Macintosh Mac OS X 10.4
: P2 Normal
Assigned To: Nobody
Depends on: 5888
  Show dependency treegraph
Reported: 2005-06-07 08:25 PDT by Nicholas Shanks
Modified: 2010-09-15 00:53 PDT (History)
4 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Nicholas Shanks 2005-06-07 08:25:42 PDT
The WebKit XSLT parser apparently ignores an XML file's DTD. This causes the following problems:

1) No custom entities are recognised. Further more, no error gets displayed stating that there were 
unrecognised entities found, they are instead silently ignored.
2) The XML document is not validated against the DTD.
3) Attributes of type "ID" (such as the 'id' attribute of XHTML) are not marked as such, causing the XSLT id
() function to fail.

An example can be found at http://astro.nickshanks.com/library/extrasolar.xml
Pre-processed HTML output can be found at http://astro.nickshanks.com/library/extrasolar.en
The two pages should look identical. The latter was produced by libxslt processing of the former.
Comment 1 Bert JW Regeer 2005-08-30 10:46:27 PDT
Adding CC.

Would also like to say that DTD does not even get parsed, but this is because Safari never downloads 
the DTD in the first place.
Comment 2 Christopher Jerome 2006-01-19 09:18:26 PST
Ah Ha!, so thats whats exactly breaking the entities test., I was going to look deeper into this when I got 
back from my cousins- a small 2 week holiday!, but looks like you have set me onto the root of the cause, 
I had an idea it was something to do with the DTD!!

so I am back to good ol' coding business!!

Chris Jerome.
Comment 3 Eric Seidel 2006-02-10 18:56:34 PST
Oops.  For better or worse I made a new bug:

and have attached the fix there.  I'm not sure if 7184 will address all of the issues covered here, but it probably will.
Comment 4 Adam Barth 2010-09-15 00:53:10 PDT
We don't respec

*** This bug has been marked as a duplicate of bug 7184 ***