Bug 3279 - CSS1: Text-decoration blink is not supported
Summary: CSS1: Text-decoration blink is not supported
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 412
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Dave Hyatt
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-06-05 15:36 PDT by Chris Petersen
Modified: 2010-08-25 20:06 PDT (History)
5 users (show)

See Also:


Attachments
Testcase that contains { text-decoration: blink } (855 bytes, text/html)
2005-06-05 15:38 PDT, Chris Petersen
no flags Details
Improved test case that uses { text-decoration: blink } (767 bytes, text/html)
2005-06-05 15:42 PDT, Chris Petersen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Petersen 2005-06-05 15:36:13 PDT
Expected Results: The text-decoration property allows text to be decorated through one of five 
properties: underline, overline, line-through, blink, or the default, none. They should be all supported.

What I got: Safari 2.0 (v412) supports all expect for (Text-decoration: blink).


Steps to reproduce:

1) Open attached filed called "test_blink.html" in Safari 2.0 (v412) under 10.4.1(8B15).
2) The first sentence uses { text-decoration: blink } put Safari doesn't apply this rule.


Note: Firefox 1.0.4 will render this paragraph correctly with  { text-decoration: blink }
Comment 1 Chris Petersen 2005-06-05 15:38:25 PDT
Created attachment 2112 [details]
Testcase that contains { text-decoration: blink }
Comment 2 Chris Petersen 2005-06-05 15:42:42 PDT
Created attachment 2113 [details]
Improved test case that uses { text-decoration: blink }
Comment 3 Chris Petersen 2005-06-07 11:15:34 PDT
Apple Bug : <rdar://problem/4141171>
Comment 4 Dave Hyatt 2005-06-09 21:43:21 PDT
The CSS specification says that user agents are free to ignore blink.  We should think carefully about 
whether or not we actually want to implement this.
Comment 5 John Sullivan 2005-06-21 11:22:33 PDT
We made a deliberate decision not to implement blink, though if there were compelling evidence that we 
should implement it our minds could be changed.
Comment 6 Jens Ayton 2005-07-14 04:31:50 PDT
A possible solution would be to allow blink if marked !important. Not that I’m a fan…
Comment 7 Joost de Valk (AlthA) 2005-09-04 23:00:28 PDT
IMHO, this should be a wontfix. Not many people will bother not having blink, and the ones who do 
probably won't even notice :)
Comment 8 Eric Seidel (no email) 2005-12-27 14:09:37 PST
I would agree.  I don't think we ever have plans to support blink.  Thanks for the bug.
Comment 9 Hiroyuki Kamisaka 2008-08-04 18:49:39 PDT
WebKit is also used on Android as its one of component.
If Android is adopted as one of the platform of Japanese carrier, The WebView
class (which is based on WebKit technology) will be used to create html mail app (viewer).

In Japan, as the greeting mail, we often use blinking string. Then the 
blinking string is realized by <blink> tag.

Therefore, if it is concluded as "WONTFIX", it becomes the restriction for 
Android platform.

So, please reconsinder to support <blink> tag on Webkit!!!
Comment 10 Laurie Denness 2009-05-21 05:04:02 PDT
You should definitely re-consider this. There are perfectly legitimate uses for blinking text, and I may have to re-consider using a Webkit based browser for our application if you will not implement a perfectly reasonable CSS property. Which would be a shame because Webkit is the only browser that doesn't leak memory like a sieve in our use case. 

See http://www.flickr.com/photos/lozzd/3210502566/

The "CRITICAL" and "DOWN" (not displayed in the picture) on this monitoring system display blinks to attract attention. Using a Webkit based browser, it is static.