Bug 32754 - Many false leaks in release builds due to PtrAndFlags
Summary: Many false leaks in release builds due to PtrAndFlags
Status: RESOLVED DUPLICATE of bug 33731
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Template Framework (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh All
: P1 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2009-12-18 16:17 PST by Alexey Proskuryakov
Modified: 2010-01-17 22:59 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2009-12-18 16:17:25 PST
I'm getting false positive leaks from Safari with ToT WebKit release build (with either FastMalloc or system allocator).

PtrAndFlags has a debug-only mechanism that makes it work with Mac OS X leaks tool. This is insufficient, because we need leaks to work in release mode, too. This is sometimes useful for WebKit development, but much more importantly, every Mac application that uses WebKit will get false positives from leaks tool.
Comment 1 Alexey Proskuryakov 2009-12-18 16:17:58 PST
<rdar://problem/7486511>
Comment 2 Gavin Barraclough 2010-01-17 22:58:02 PST

*** This bug has been marked as a duplicate of bug 33731 ***
Comment 3 Gavin Barraclough 2010-01-17 22:59:18 PST
Duped to newer bug, filed in error, since that now has more info (i.e. patches).