Bug 32299 - Cannot open a lot of WebSocket connections
Summary: Cannot open a lot of WebSocket connections
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-08 17:38 PST by Alexey Proskuryakov
Modified: 2010-01-19 08:25 PST (History)
4 users (show)

See Also:


Attachments
test case (to be run locally) (758 bytes, text/html)
2009-12-08 17:38 PST, Alexey Proskuryakov
no flags Details
Update pywebsocket to 0.4.6 (4.03 KB, patch)
2010-01-05 03:06 PST, Yuzo Fujishima
ap: review+
ap: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2009-12-08 17:38:52 PST
Created attachment 44500 [details]
test case (to be run locally)

Not sure if it's a SocketStreamHandleCFNet or pywebsocket issue, but I couldn't open more than a few dozen connections to a local WebSocket server.

Please see attached test case. I'm getting results as low as 25 or as high as 89 randomly.

I want to have at least some large number guaranteed to make a test verifying that WebSocket is not subject to HTTP connection limit (currently 4 or 6 in different implementations, but it would be best to set a much higher threshold in the test).
Comment 1 Yuzo Fujishima 2009-12-16 01:56:19 PST
A fix is under review now in the upstream. If you are in a hurry, please
make the following change:
http://code.google.com/p/pywebsocket/source/diff?format=side&show=review&spec=issue34&r=147&path=/branches/moreconn/src/mod_pywebsocket/standalone.py

Yuzo
Comment 2 Yuzo Fujishima 2010-01-05 03:06:57 PST
Created attachment 45878 [details]
Update pywebsocket to 0.4.6
Comment 3 WebKit Review Bot 2010-01-05 03:10:50 PST
style-queue ran check-webkit-style on attachment 45878 [details] without any errors.
Comment 4 Alexey Proskuryakov 2010-01-05 08:34:37 PST
Comment on attachment 45878 [details]
Update pywebsocket to 0.4.6

r=me. The patch doesn't include a test case - would be nice to land the attached one at the same time.
Comment 5 Eric Seidel (no email) 2010-01-14 13:04:06 PST
Ping?  This has been in the pending-commit list for 7 days w/o comment.  Just checking in...
Comment 6 Fumitoshi Ukai 2010-01-14 20:57:01 PST
Committed r53317: <http://trac.webkit.org/changeset/53317>
Comment 7 Alexey Proskuryakov 2010-01-18 11:57:21 PST
Test landed in bug 33804.
Comment 9 Fumitoshi Ukai 2010-01-19 01:46:43 PST
(In reply to comment #8)
> This doesn't quite work on Windows:
> <http://build.webkit.org/results/Windows%20Debug%20(Tests)/r53421%20(8654)/websocket/tests/multiple-connections-pretty-diff.html>.

This is the cause?
2010-01-18 13:25:39.906 DumpRenderTree_debug.exe[2688:994] *** More than MAXIMUM_WAIT_OBJECTS (64) ports add to a port set.  The last ones will be ignored.

http://build.webkit.org/results/Windows%20Debug%20(Tests)/r53421%20(8654)/websocket/tests/multiple-connections-stderr.txt
Comment 10 Alexey Proskuryakov 2010-01-19 08:25:23 PST
Sounds like that!

64 is enough for my purposes - changed the test to only make 50 connections.