RESOLVED FIXED 32284
move code generation portions of Nodes.cpp to bytecompiler directory
https://bugs.webkit.org/show_bug.cgi?id=32284
Summary move code generation portions of Nodes.cpp to bytecompiler directory
Maciej Stachowiak
Reported 2009-12-08 12:58:53 PST
Move code generation portions of Nodes.cpp to the bytecompiler directory. This is not really part of the parser.
Attachments
Patch (192.26 KB, patch)
2009-12-08 13:01 PST, Maciej Stachowiak
darin: review+
Maciej Stachowiak
Comment 1 2009-12-08 13:01:17 PST
WebKit Review Bot
Comment 2 2009-12-08 13:03:38 PST
Attachment 44479 [details] did not pass style-queue: Failed to run "WebKitTools/Scripts/check-webkit-style" exit_code: 1 JavaScriptCore/bytecompiler/NodesCodegen.cpp:27: You should add a blank line after implementation file's own header. [build/include_order] [4] JavaScriptCore/bytecompiler/NodesCodegen.cpp:30: Alphabetical sorting problem. [build/include_order] [4] JavaScriptCore/bytecompiler/NodesCodegen.cpp:270: A case label should not be indented, but line up with its switch statement. [whitespace/indent] [4] JavaScriptCore/bytecompiler/NodesCodegen.cpp:538: One line control clauses should not use braces. [whitespace/braces] [4] JavaScriptCore/bytecompiler/NodesCodegen.cpp:552: One line control clauses should not use braces. [whitespace/braces] [4] JavaScriptCore/bytecompiler/NodesCodegen.cpp:575: One line control clauses should not use braces. [whitespace/braces] [4] JavaScriptCore/bytecompiler/NodesCodegen.cpp:598: One line control clauses should not use braces. [whitespace/braces] [4] JavaScriptCore/bytecompiler/NodesCodegen.cpp:1066: A case label should not be indented, but line up with its switch statement. [whitespace/indent] [4] JavaScriptCore/bytecompiler/NodesCodegen.cpp:1121: One line control clauses should not use braces. [whitespace/braces] [4] JavaScriptCore/bytecompiler/NodesCodegen.cpp:1269: An else statement can be removed when the prior "if" concludes with a return, break, continue or goto statement. [readability/control_flow] [4] JavaScriptCore/bytecompiler/NodesCodegen.cpp:1753: min_num is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] JavaScriptCore/bytecompiler/NodesCodegen.cpp:1754: max_num is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Total errors found: 12
Maciej Stachowiak
Comment 3 2009-12-08 13:21:59 PST
I did not fix the style issues identified by the bot, since this was pure code motion, but I will do that in a separate patch.
Note You need to log in before you can comment on or make changes to this bug.