Bug 32227 - With @font-face, SVG fonts only work as primary, non-segmented
Summary: With @font-face, SVG fonts only work as primary, non-segmented
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on: 59085
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-07 09:55 PST by mitz
Modified: 2011-06-20 01:29 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2009-12-07 09:55:42 PST
When used in @font-face, SVG fonts don’t work as a fallback font or in conjunction with other sources for the same family, segmented by Unicode-range. The problem is that the Font methods, e.g. drawText(), check the primary font for SVG-ness and take an entirely different code path for that case.
Comment 1 mitz 2009-12-07 09:56:04 PST
<rdar://problem/7449131>
Comment 2 mitz 2010-05-04 01:09:05 PDT
One particular nasty issue was discovered by Joseph Pecoraro: GlyphPage::fill() can get called with an SVG font, even though SVG fonts don’t use the glyph cache, if the primary font is non-SVG, but there are SVG segments (apparently one way this can happen is if the SVG font is still loading or failed to load).
Comment 3 Joseph Pecoraro 2010-05-04 11:27:27 PDT
(In reply to comment #2)
> One particular nasty issue was discovered by Joseph Pecoraro: GlyphPage::fill()
> can get called with an SVG font, even though SVG fonts don’t use the glyph
> cache, if the primary font is non-SVG, but there are SVG segments (apparently
> one way this can happen is if the SVG font is still loading or failed to load).

I opened a separate bug on my issue, because I don't think it would entirely fix this bug:
https://bugs.webkit.org/show_bug.cgi?id=38530
Comment 4 Nikolas Zimmermann 2010-07-09 07:16:27 PDT
Changed component to SVG, so it shows up in my all-svg-bugs search.
Comment 5 mitz 2010-07-09 10:43:49 PDT
See also bug 34236.
Comment 6 Nikolas Zimmermann 2011-06-20 01:29:04 PDT
Fixed in r89233.