Bug 32224 - Turn on (SVG) Filters support, by default.
: Turn on (SVG) Filters support, by default.
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: SVG
: 528+ (Nightly build)
: PC Mac OS X 10.5
: P2 Normal
Assigned To: Nikolas Zimmermann
:
Depends on:
Blocks: 68469 26389
  Show dependency treegraph
 
Reported: 2009-12-07 08:59 PST by Nikolas Zimmermann
Modified: 2014-05-12 05:54 PDT (History)
6 users (show)

See Also:


Attachments
Patch, excluding LayoutTests changes (159.94 KB, patch)
2009-12-07 09:36 PST, Nikolas Zimmermann
no flags Details | Formatted Diff | Diff
Build patches for win (25.20 KB, patch)
2009-12-08 08:10 PST, Nikolas Zimmermann
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nikolas Zimmermann 2009-12-07 08:59:31 PST
Enable (SVG) Filters support by default. The plan is to enable build on Mac only. The other platforms Skipped list will be adapted, to not run any test affected by the filter feature. If mac port builds fine, and the build bots are green again, the other platforms should be enabled one after another. Uploading a patch soon.
Comment 1 Nikolas Zimmermann 2009-12-07 09:36:40 PST
Created attachment 44418 [details]
Patch, excluding LayoutTests changes

Follow-up patch, will contain the LayoutTest results (big list of changes, all filter affected tests have to be rebaselined).
Comment 2 WebKit Review Bot 2009-12-07 09:41:09 PST
style-queue ran check-webkit-style on attachment 44418 [details] without any errors.
Comment 3 Holger Freyther 2009-12-07 09:58:13 PST
Comment on attachment 44418 [details]
Patch, excluding LayoutTests changes


> +        Turn on (SVG) Filters support, by default.
> +        https://bugs.webkit.org/show_bug.cgi?id=32224

rs=me from the impressions I got from the webkit-dev thread. According to Niko we do have enough auto tests for SVG filters.
Comment 4 Nikolas Zimmermann 2009-12-07 15:04:55 PST
Landed patch enabling mac build in r51800. Waiting for bot results before proceeding.
Comment 5 Nikolas Zimmermann 2009-12-07 15:44:01 PST
Comment on attachment 44418 [details]
Patch, excluding LayoutTests changes

Clearing review flag, this patch has been landed.
Comment 6 Nikolas Zimmermann 2009-12-08 03:01:53 PST
All mac build slaves work fine, w/o regression since turning on filters.
Qt has filters turned out, w/o layout test failures since r51841.
Now gtk...
Comment 7 Nikolas Zimmermann 2009-12-08 03:02:12 PST
(In reply to comment #6)
> All mac build slaves work fine, w/o regression since turning on filters.
> Qt has filters turned out, w/o layout test failures since r51841.
> Now gtk...
s/turned out/turned on/
Comment 8 Nikolas Zimmermann 2009-12-08 06:39:59 PST
Gtk + Filters work properly after r51847 (bots green).
Comment 9 Nikolas Zimmermann 2009-12-08 08:10:44 PST
Created attachment 44473 [details]
Build patches for win

Adding the win patches, so I can show them around before landing. Already got a blind rs=mjs, given that I'm willing to watch builds and fix :-)
Comment 10 Dirk Schulze 2010-01-01 06:56:00 PST
(In reply to comment #9)
> Created an attachment (id=44473) [details]
> Build patches for win
> 
> Adding the win patches, so I can show them around before landing. Already got a
> blind rs=mjs, given that I'm willing to watch builds and fix :-)

Filter are activated on every port. Can we close this bug now?
Comment 11 Nikolas Zimmermann 2010-01-02 07:01:19 PST
Agreed. Closing.