Bug 32175 - REGRESSION: websocket/tests/url-parsing.html is crashing on Leopard Bot
Summary: REGRESSION: websocket/tests/url-parsing.html is crashing on Leopard Bot
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.5
: P2 Normal
Assignee: Alexey Proskuryakov
URL:
Keywords:
: 32091 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-12-04 15:13 PST by Eric Seidel (no email)
Modified: 2009-12-05 15:59 PST (History)
3 users (show)

See Also:


Attachments
proposed fix (1.77 KB, patch)
2009-12-04 16:43 PST, Alexey Proskuryakov
eric: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2009-12-04 15:13:22 PST
REGRESSION: websocket/tests/url-parsing.html is crashing on Leopard Bot

It just crashed the last 3 builds in a row:
http://build.webkit.org/results/Leopard%20Intel%20Debug%20(Tests)/r51714%20(7901)/results.html
http://build.webkit.org/results/Leopard%20Intel%20Debug%20(Tests)/r51715%20(7901)/results.html
http://build.webkit.org/results/Leopard%20Intel%20Debug%20(Tests)/r51716%20(7901)/results.html

It does not seem related to the r51714 checkin however.
Comment 1 Alexey Proskuryakov 2009-12-04 16:12:33 PST
I do sometimes get this assertion on Leopard, but never on SnowLeopard.
Comment 2 Darin Adler 2009-12-04 16:13:11 PST
Makes it sound like a CFNetwork bug.
Comment 3 Alexey Proskuryakov 2009-12-04 16:43:01 PST
Created attachment 44340 [details]
proposed fix

I think it's just a change in behavior in CFNetwork, not a bug.

The fix is a little heavy-handed, as there is no need to call CFWriteStreamClose(), and probably no need to unschedule the read stream. But it seems to work fine in my testing.
Comment 4 Alexey Proskuryakov 2009-12-04 16:44:23 PST
*** Bug 32091 has been marked as a duplicate of this bug. ***
Comment 5 WebKit Review Bot 2009-12-04 16:48:16 PST
style-queue ran check-webkit-style on attachment 44340 [details] without any errors.
Comment 6 Eric Seidel (no email) 2009-12-05 13:05:57 PST
Comment on attachment 44340 [details]
proposed fix

OK.  Here's hoping it stops the crashes. :)
Comment 7 Alexey Proskuryakov 2009-12-05 15:59:38 PST
Committed revision 51732.