Bug 32170 - [GTK] Needs proper reporting of frame loader callbacks, in DRT
Summary: [GTK] Needs proper reporting of frame loader callbacks, in DRT
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks:
 
Reported: 2009-12-04 13:47 PST by Gustavo Noronha (kov)
Modified: 2010-02-26 14:40 PST (History)
3 users (show)

See Also:


Attachments
proposed fix (9.24 KB, patch)
2009-12-04 14:46 PST, Gustavo Noronha (kov)
xan.lopez: review+
gustavo: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gustavo Noronha (kov) 2009-12-04 13:47:48 PST
Some tests fail because of missing reporting of frame loader callbacks. Some examples:

fast/loader/stateobjects/document-destroyed-navigate-back-with-fragment-scroll.html
fast/loader/stateobjects/document-destroyed-navigate-back.html
http/tests/loading/state-object-security-exception.html
Comment 1 Gustavo Noronha (kov) 2009-12-04 14:46:13 PST
Created attachment 44337 [details]
proposed fix
Comment 2 Gustavo Noronha (kov) 2009-12-04 14:47:29 PST
I would like to advocate this solution to the delegates reporting problem. It's also a very good way of experimenting with new API - we can get to know the signals we might need, and can promote them to proper API in the appropriate time. Xan? =)
Comment 3 WebKit Review Bot 2009-12-04 14:51:28 PST
Attachment 44337 [details] did not pass style-queue:

Failed to run "WebKitTools/Scripts/check-webkit-style" exit_code: 1
WebKit/gtk/webkit/webkitwebview.cpp:2065:  Use 0 instead of NULL.  [readability/null] [5]
WebKitTools/DumpRenderTree/gtk/DumpRenderTree.cpp:586:  Declaration has space between type name and * in char *frameName  [whitespace/declaration] [3]
Total errors found: 2
Comment 4 Christian Dywan 2009-12-17 01:36:31 PST
I think you want this to be a WebKitLoadStatus instead of a new signal.
Comment 5 Gustavo Noronha (kov) 2009-12-17 08:09:13 PST
(In reply to comment #4)
> I think you want this to be a WebKitLoadStatus instead of a new signal.

As discussed in real life ;D, I prefer keeping it as a semi-private signal for now, because otherwise we will be adding stuff to a public enum, and there's no going back. We can probably add it to the load status when we decide it is a good API.

Also, I think it is not a good idea to have 1.1.18 Since tag, so I'll remove it when committing, if I get an r+.
Comment 6 Xan Lopez 2010-02-25 05:57:39 PST
Comment on attachment 44337 [details]
proposed fix

I agree this is the best solution for the moment, since we'll need to add A TON of signals for all tests to pass and we shouldn't commit to their stability without a proper period of testing. So r=me
Comment 7 Gustavo Noronha (kov) 2010-02-26 14:40:45 PST
This first step just went in as r55316.