Bug 31957 - Error in -webkit-transition rendering of <select> height and width
Summary: Error in -webkit-transition rendering of <select> height and width
Status: RESOLVED DUPLICATE of bug 16020
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 525.x (Safari 3.2)
Hardware: PC Windows XP
: P5 Minor
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-28 16:30 PST by Michael Kozakewich
Modified: 2009-11-29 15:03 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Kozakewich 2009-11-28 16:30:50 PST
When using CSS to transition the height or width of a <select> element, the box immediately shrinks to zero, and then expands over the transition duration until it reaches the final value as specified by the CSS.

The following CSS crashes the entire page, in Google Chrome.
select:hover{
height:200px;opacity:0;
-webkit-transition:all 5s;}

Safari doesn't crash, but the transition starts at 0, instead of at the current height.

I imagine the priority isn't too great at this moment in time, because the height of <select> elements aren't often changed while using the -webkit-transition in combination with opacity.
Comment 1 mitz@webkit.org 2009-11-29 10:56:24 PST
Duplicate of bug 16020?
Comment 2 Michael Kozakewich 2009-11-29 15:03:26 PST
I guess my bug search was looking for different syntax.
Transitioning both opacity and height of a <select> still crashes Chrome, but I guess that's their problem.
It looks like the underlying problem is covered by bug 16020.

*** This bug has been marked as a duplicate of bug 16020 ***