Bug 31885 - Support reflections on composited layers
Summary: Support reflections on composited layers
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
: 31899 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-11-25 12:21 PST by Simon Fraser (smfr)
Modified: 2010-01-15 21:08 PST (History)
3 users (show)

See Also:


Attachments
Patch: part 1 (16.71 KB, patch)
2009-11-25 14:55 PST, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Patch (142.37 KB, patch)
2009-12-11 16:20 PST, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Followup patch for reflected canvas3d (5.88 KB, patch)
2009-12-11 17:29 PST, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Patch (550.48 KB, patch)
2010-01-15 13:03 PST, Simon Fraser (smfr)
mitz: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2009-11-25 12:21:02 PST
This bug will track changes related to implementing hardware-accelerated reflections on compositing layers.
Comment 1 Simon Fraser (smfr) 2009-11-25 12:22:23 PST
<rdar://problem/6999594&6999610&7248172>
Comment 2 Simon Fraser (smfr) 2009-11-25 14:55:08 PST
Created attachment 43871 [details]
Patch: part 1
Comment 3 Darin Adler 2009-11-30 15:54:08 PST
Comment on attachment 43871 [details]
Patch: part 1

> +    if (m_structuralLayer || m_contentsLayer || childLayers.size() > 0) {

In WebKit style we'd normally omit that "> 0".

> +            updateLayerPosition();
> +            updateLayerSize();
> +            updateAnchorPoint();
> +            updateTransform();
> +            updateChildrenTransform();
>  
> +            updateSublayerList();
> +            updateOpacityOnLayer();

This is kind of funny -- and it's repeated more than once. Shouldn't this also be calling updateLayerNames?

r=me
Comment 4 Simon Fraser (smfr) 2009-12-11 15:50:11 PST
Comment on attachment 43871 [details]
Patch: part 1

This patch committed: http://trac.webkit.org/changeset/52029
Comment 5 Simon Fraser (smfr) 2009-12-11 16:20:40 PST
Created attachment 44716 [details]
Patch
Comment 6 Simon Fraser (smfr) 2009-12-11 17:29:32 PST
Created attachment 44718 [details]
Followup patch for reflected canvas3d

Stashing this patch here; will clean up and submit with changelog once the previous patch is committed.
Comment 7 Eric Seidel (no email) 2009-12-14 13:32:26 PST
I'm unclear as to if this mega-patch is still supposed to be up for review?
Comment 8 Simon Fraser (smfr) 2009-12-14 13:34:06 PST
Yes, it is. I'll fix up canvas3d in a separate patch.
Comment 9 Simon Fraser (smfr) 2009-12-16 12:40:22 PST
*** Bug 31899 has been marked as a duplicate of this bug. ***
Comment 10 Eric Seidel (no email) 2010-01-06 23:38:46 PST
It's been another 3 weeks, looking through the pending-commit queue and just wanted to check back on the state of this patch.
Comment 11 Simon Fraser (smfr) 2010-01-07 08:22:42 PST
The patch still needs review. I had some interest from Sam and Dan.
Comment 12 Eric Seidel (no email) 2010-01-07 11:44:10 PST
Comment on attachment 43871 [details]
Patch: part 1

Clearing Darin Adler's r+ on this obsolete patch so this doesn't show up in the pending-commit list.
Comment 13 Simon Fraser (smfr) 2010-01-15 13:03:53 PST
Created attachment 46706 [details]
Patch
Comment 14 Eric Seidel (no email) 2010-01-15 13:25:07 PST
Attachment 46706 [details] did not build on mac:
Build output: http://webkit-commit-queue.appspot.com/results/189495
Comment 15 mitz 2010-01-15 15:05:54 PST
Comment on attachment 46706 [details]
Patch

r=me w/ a few cooments made in person
Comment 16 Simon Fraser (smfr) 2010-01-15 21:08:15 PST
http://trac.webkit.org/changeset/53357