Bug 31726 - StringHash::equal is unsafe on platforms which aren't 4-byte aligned
Summary: StringHash::equal is unsafe on platforms which aren't 4-byte aligned
Status: RESOLVED DUPLICATE of bug 31475
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other Other
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-20 09:27 PST by Steve Block
Modified: 2009-11-20 16:07 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Block 2009-11-20 09:27:40 PST
Code in StringHash::equal accesses memory as 32-bit values assuming 4-byte alignment.
This is unsafe on some platforms, eg ARM.

Note that this problem is equivalent to that fixed in AtomicString with http://trac.webkit.org/changeset/19930
Comment 1 Alexey Proskuryakov 2009-11-20 16:07:43 PST
This was recently fixed.

*** This bug has been marked as a duplicate of bug 31475 ***