To abstract the work of holding the collection of patches from the queues.
Created attachment 43287 [details]
Comment on attachment 43287 [details]
def __len__(self): return len(self._patches)
instead of size()
And the test needs more comments.
I trust you to make those edits.
Committed r51026: <http://trac.webkit.org/changeset/51026>