Bug 31514 - not implemented 'x' and 'y' attribute for tag <use>
Summary: not implemented 'x' and 'y' attribute for tag <use>
Status: CLOSED DUPLICATE of bug 30342
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-14 18:24 PST by Konstantin Kokarev
Modified: 2009-11-18 01:46 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantin Kokarev 2009-11-14 18:24:25 PST
all 'used' objects only with 0,0 coordinate

example:
<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
<svg width="10cm" height="3cm" viewBox="0 0 100 100" version="1.1"  xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
  <defs><rect id="test" width="10" height="10" /></defs>
  <use x="10" y="10" xlink:href="#test" />
  <use x="10" y="30" xlink:href="#test" />
  <use x="10" y="50" xlink:href="#test" />
</svg>

see also:
http://www.w3.org/TR/SVG11/struct.html#UseElement
example: http://www.w3.org/TR/SVG11/images/struct/Use01.svg
should be: http://www.w3.org/TR/SVG11/images/struct/Use01.png

linux, webkit night build (r50918), midori browser.
Comment 1 Konstantin Kokarev 2009-11-14 20:21:32 PST
http://www.w3.org/TR/SVG11/images/struct/Use01.svg:

passed = rectangle in center, failed = top-left

-----------------------------

midori (webkitgtk) - failed
chromium (webkitgtk) - failed

arora (libqtwebkit) - passed
konqueror + webkitpart (libqtwebkit) - failed
qt demo browser (libqtwebkit) - passed

-----------------------------

firefox (gecko) - passed
epiphany (gecko) - passed
opera (opera) - passed
konqueror(khtml) - passed
qt demo svgviewer (libqtsvg) - passed
Comment 2 Dirk Schulze 2009-11-18 01:02:35 PST
x and y are implemented. It's a problem of system local, use LANG="C" and you'll see that it works.

*** This bug has been marked as a duplicate of bug 30342 ***
Comment 3 Konstantin Kokarev 2009-11-18 01:46:26 PST
It`s work. Thanks.