Bug 31501 - Make WebSocket tests work on Tiger
Summary: Make WebSocket tests work on Tiger
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 31603
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-13 17:45 PST by Alexey Proskuryakov
Modified: 2009-11-19 14:38 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2009-11-13 17:45:23 PST
Currently, tests time out, so I'm disabling them back:

websocket/tests .
command timed out: 1200 seconds without output, killing pid 12952
process killed by signal 9
program finished with exit code -1
elapsedTime=1905.071402
Comment 1 Yuzo Fujishima 2009-11-15 22:10:45 PST
Assuming Tiger's python doesn't include pyOpenSSL,
this may be fixed by the patch attached to:
https://bugs.webkit.org/show_bug.cgi?id=31479

Yuzo
Comment 2 Alexey Proskuryakov 2009-11-16 10:11:08 PST
The patch that disables pyOpenSSL does help.

*** This bug has been marked as a duplicate of bug 31479 ***
Comment 3 Alexey Proskuryakov 2009-11-16 15:18:45 PST
This helped on my machine locally, but buildbot still doesn't work: <http://build.webkit.org/builders/Tiger%20Intel%20Release/builds/6222/steps/layout-test/logs/stdio>.
Comment 4 Alexey Proskuryakov 2009-11-17 16:32:16 PST
Could be a duplicate of bug 31603.
Comment 6 Alexey Proskuryakov 2009-11-19 14:38:35 PST
Something changed on Tiger buildbot slave, and tests pass now.