Bug 31260 - Web Inspector: Main Resources Other than HTML are mis-detected
Summary: Web Inspector: Main Resources Other than HTML are mis-detected
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Brian Weinstein
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-09 09:25 PST by Denis Ahrens
Modified: 2009-11-12 14:26 PST (History)
7 users (show)

See Also:


Attachments
[PATCH] (3.07 KB, patch)
2009-11-12 14:14 PST, Brian Weinstein
timothy: review+
bweinstein: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Denis Ahrens 2009-11-09 09:25:20 PST
The Web Inspector does not know that an TIFF image with Content-Type: image/tiff is an image and decodes it as text. This leads to a very high memory footprint. In my case it was an image with 2500x2000 pixel which needed more than 800MB memory.

Simply load http://plugindoc.mozdev.org/testpages/dscf1665.tiff and go to the inspector. In the resources you see it is decoded as text.

Tested it on actual Safari and Webkit from today!
Comment 1 Patrick Mueller 2009-11-12 12:33:49 PST
I did a test of creating a small HTML file that has an <img> with the referenced URL as the source attribute.  That works fine.

bweinstein has determined that the problem is caused when you load an image - any image - or any non HTML thing really - as your main URL in the browser.  It's not actually a TIFF problem.

For instance, you'll see the same thing if you load the following URL in the location bar of the browser:

   http://webkit.org/images/download.png
Comment 2 Brian Weinstein 2009-11-12 14:14:32 PST
Created attachment 43097 [details]
[PATCH]
Comment 3 Brian Weinstein 2009-11-12 14:26:19 PST
Landed in r50905.