Bug 31136 - ruby text vertical space problem when zooming back and forth
Summary: ruby text vertical space problem when zooming back and forth
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL: https://bug-31136-attachments.webkit....
Keywords:
Depends on:
Blocks:
 
Reported: 2009-11-04 11:47 PST by Michael[tm] Smith
Modified: 2022-06-14 21:12 PDT (History)
6 users (show)

See Also:


Attachments
test case (734 bytes, text/html)
2009-11-04 11:47 PST, Michael[tm] Smith
no flags Details
screen capture (16.27 KB, image/png)
2009-11-04 11:48 PST, Michael[tm] Smith
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael[tm] Smith 2009-11-04 11:47:57 PST
Created attachment 42503 [details]
test case

1. Open the attached HTML file.
2. Zoom In the page, all the way in.
3. Reload the page while it’s zoomed in.
4. Zoom Out the page back to Actual Size.

You’ll notice that in the first paragraph of the page there is now a large amount of vertical white space between the ruby text and the base text (see the attached screen capture).
Comment 1 Michael[tm] Smith 2009-11-04 11:48:36 PST
Created attachment 42504 [details]
screen capture
Comment 2 Dave Hyatt 2010-11-20 19:30:46 PST
Might have been fixed by my rewrite of how rubies position themselves vertically...
Comment 3 Michael[tm] Smith 2010-11-21 22:56:10 PST
(In reply to comment #2)
> Might have been fixed by my rewrite of how rubies position themselves vertically...

Dunno when that landed, but I just tried the test case in an r72487 WebKit nightly, and I see the same behavior I reported originally (that is, it does not seem to be fixed yet).
Comment 4 Ahmad Saleem 2022-06-14 14:49:15 PDT
I am not able to reproduce this bug in Safari 15.5 on macOS 12.4. By zooming-in and then reloading and then zooming-out, there is no hanging text with vertical space. It shows as normal text. Thanks!
Comment 5 zalan 2022-06-14 21:12:53 PDT
Thank you for testing it!