The gtk and windows ports implement FrameLoaderClient::objectContentType using the exact same code, except for different variable names and comments. (The qt port uses almost the same code except that it checks for several more cases. The mac port is very different, with lots of Obj-C'isms. The wx and haiku ports don't implement it at all.)
It would be good to move this shared code to a utility function, such as defaultObjectContentType. Ports could choose to implement objectContentType either by calling the utility function or doing their own processing.
Created attachment 42037 [details]
Move shared code to FrameLoader::defaultObjectContentType
This patch moves the shared code to FrameLoader::defaultObjectContentType. The haiku and wx ports could now implement objectContentType by calling this function, but I didn't do that because I wanted to make sure I didn't make any functional changes.
Created attachment 42038 [details]
same patch, with build fix for gtk
Please make sure to watch the buildbots like a hawk when this patch lands.
Committed revision 50225.
Created attachment 42044 [details]
build fix for windows
Created attachment 42045 [details]
build fix for mac
Are these fixes still needed? If so, please attach them as a single patch with one ChangeLog. Otherwise please clear the review flags as this bug is closed.
Thank you George!