Clean up the DOM Storage runtime flag stuff to match the new way of doing things.
Created attachment 41908 [details]
Comment on attachment 41908 [details]
r=me, except -- I don't know for sure, but I think all new code uses just camelCase for statics. Can you change that back?
I've seen more static variables without s_, and Eric raised the same question when I uploaded a patch with s_ static variables. So I think we should get rid of the s_ prefix.
Also, I don't see why 'enabled' is better than 'isEnabled': ~15 'bool enabled' parameters in ~5 different .cpp files in all of WebCore can hardly be called a 'standard'. But I don't feel strongly about this.
I switched back to isBlahBlahEnabled and isEnabled. Didn't realize those were the more accepted conventions. (Kind of wish that, whenever such decisions are made, that people would just change everything over right away....it's so hard knowing what's currently in favor!)
Committed r50113: <http://trac.webkit.org/changeset/50113>