Bug 30755 - [Qt] Conditional jump on uninitialized variable in QWebSettings
Summary: [Qt] Conditional jump on uninitialized variable in QWebSettings
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Qt (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Major
Assignee: Nobody
URL:
Keywords: Qt
Depends on: 29042
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-25 04:39 PDT by Jakob Truelsen
Modified: 2009-11-13 04:55 PST (History)
4 users (show)

See Also:


Attachments
Fix unitialize valiabels (1.48 KB, patch)
2009-10-25 04:44 PDT, Jakob Truelsen
eric: review-
Details | Formatted Diff | Diff
Fix uninitialized vars and ABI issues (4.24 KB, patch)
2009-11-12 03:14 PST, Jakob Truelsen
abarth: review-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jakob Truelsen 2009-10-25 04:39:31 PDT
When I made the patch in https://bugs.webkit.org/show_bug.cgi?id=29042. I did not fully understand the QWebSettings class.  The result is that calling apply will result in a jump on an uninitialized variable.
Comment 1 Jakob Truelsen 2009-10-25 04:44:08 PDT
Created attachment 41818 [details]
Fix unitialize valiabels

Fix uninitialized variabels and give global variabels default values (copied from within webkit)
Comment 2 Eric Seidel (no email) 2009-10-26 14:50:31 PDT
Comment on attachment 41818 [details]
Fix unitialize valiabels

Why change the defaults?  That's not documented in the Changelog.

Also, are these the only defaults that constructor misses?  What about defaultTextEncoding?
Comment 3 Jakob Truelsen 2009-10-26 23:55:17 PDT
The default was changed to bring it in line with other variables, such as defaultTextEncoding, but I can not do that if you like.  The defaultTextEncoding is a QString, so naturally it cannot be uninitialized.  There wight have been other floates, ints, or bools that where unititialized, but I do not think so. At least valgrind did not complain about this.
Comment 4 Jakob Truelsen 2009-11-12 03:14:40 PST
Created attachment 43053 [details]
Fix uninitialized vars and ABI issues
Comment 5 Jocelyn Turcotte 2009-11-12 06:23:02 PST
Duplicate of bug #31058
Please ensure that both bugs are closed when the issue is resolved.
Comment 6 Adam Barth 2009-11-12 20:47:54 PST
Comment on attachment 43053 [details]
Fix uninitialized vars and ABI issues

No test.
Comment 7 Kenneth Rohde Christiansen 2009-11-13 04:55:57 PST
The patch that introduced this change was reverted, so this should be part of a newer version of that patch, when reintroduced. Marking invalid.