Bug 30746 - REGRESSION (r48687): Wachovia Online Billpay website broken
Summary: REGRESSION (r48687): Wachovia Online Billpay website broken
Status: RESOLVED DUPLICATE of bug 30424
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P1 Normal
Assignee: Nobody
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2009-10-24 11:54 PDT by Justin Hibbits
Modified: 2009-10-27 09:40 PDT (History)
5 users (show)

See Also:


Attachments
Reduction (118 bytes, text/html)
2009-10-25 13:55 PDT, Daniel Bates
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Hibbits 2009-10-24 11:54:17 PDT
With webkit 1.1.15.2 and later I can no longer access the Wachovia Online Billpay page, clicking the "Pay bills" from the main account page just directs to a blank page.  Webkit 1.1.15.1 and earlier correctly handle the redirects.
Comment 1 Mark Rowe (bdash) 2009-10-24 16:42:45 PDT
Can you please provide a URL that can be used to reproduce this?
Comment 2 Justin Hibbits 2009-10-24 18:36:38 PDT
https://www.wachovia.com is the top-level page.  But an account is required in order to test the Bill Pay link.  The actual bill pay link within the account realm is generated with javascript.
Comment 3 Justin Hibbits 2009-10-24 18:44:52 PDT
I will note that this also occurs with Safari, using the OS X Webkit nightly svn revision 50006.
Comment 4 Mark Rowe (bdash) 2009-10-24 21:27:31 PDT
<rdar://problem/7334141>
Comment 5 Daniel Bates 2009-10-25 13:55:59 PDT
Created attachment 41827 [details]
Reduction

Here is a reduction.

When you click on Pay Bills the browser is taken to the page: https://onlineservices.wachovia.com/NASApp/NavApp/Titanium (i.e. the link actually submits a form with some parameters).

The issue seems to be caused by the script that appears in the <head> of the HTTP response: <script>history.go(1)</script>. This script causes the browser to redirect to the next page in the history (i.e. equivalent to clicking the Forward button in the browser). But, no such history entry exists yet! (it would only exist if, say, we clicked on a link on this page then pressed the Back button in the browser).
Comment 6 Daniel Bates 2009-10-25 14:26:38 PDT
Confirmed this is a regression that affects Macintosh PowerPC, Macintosh Intel, and Windows XP using r50039 for Mac, r49956 for Windows.

Works in Safari Version 4.0.3 (5531.9).
Comment 7 Daniel Bates 2009-10-25 14:45:37 PDT
This regression first appeared in nightly build r48730.

If I have some time, I'll try to bisect from r48680 (works) to r48730 (does not work) and find the culprit revision.
Comment 8 Daniel Bates 2009-10-26 19:53:08 PDT
Confirmed r48687 is the cause, <http://trac.webkit.org/changeset/48687>.

CC'ing Darin and Sam.
Comment 9 Mark Rowe (bdash) 2009-10-26 19:54:18 PDT
Brady fixed two issues that were fallout from r48687 today.  Does this still occur with ToT?
Comment 10 Brady Eidson 2009-10-26 21:41:58 PDT
This is almost certainly a dupe of http://webkit.org/b/30424 and was almost certainly fixed by http://trac.webkit.org/changeset/50111 but I can't verify right now.

*** This bug has been marked as a duplicate of bug 30424 ***