Bug 30675 - Inspector injects _inspectorCommandLineAPI into global object when opened
Summary: Inspector injects _inspectorCommandLineAPI into global object when opened
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-22 08:39 PDT by Martin Häcker
Modified: 2009-10-23 12:31 PDT (History)
7 users (show)

See Also:


Attachments
Showcase of the problem (412 bytes, text/html)
2009-10-22 08:39 PDT, Martin Häcker
no flags Details
proposed patch (4.52 KB, patch)
2009-10-22 18:18 PDT, Keishi Hattori
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Häcker 2009-10-22 08:39:10 PDT
Created attachment 41659 [details]
Showcase of the problem

This is of course disturbing my unit tests which check if I accidentally pollute the global object with any new keys.

I guess this is not intentional, but instead because there is a var statement missing in front o f a variable declaration.

This is a regression as Safari 4 does not behave like this.
Comment 1 Martin Häcker 2009-10-22 08:40:21 PDT
You may need to reload the example a few times for the problem to show up.
Comment 2 Martin Häcker 2009-10-22 08:40:39 PDT
Drat. With the Inspector open that is.
Comment 3 Keishi Hattori 2009-10-22 18:18:58 PDT
Created attachment 41709 [details]
proposed patch

Moved _inspectorCommandLineAPI to console. _inspectorCommandLineAPI
I guess will be safer.
Comment 4 WebKit Commit Bot 2009-10-23 02:46:55 PDT
Comment on attachment 41709 [details]
proposed patch

Rejecting patch 41709 from commit-queue.

Failed to run "['WebKitTools/Scripts/run-webkit-tests', '--no-launch-safari', '--quiet', '--exit-after-n-failures=1']" exit_code: 1
Running build-dumprendertree
Running tests from /Users/eseidel/Projects/CommitQueue/LayoutTests
Testing 11506 test cases.
fast/media/mq-transform-02.html -> failed

Exiting early after 1 failures. 7441 tests run.
139.35s total testing time

7440 test cases (99%) succeeded
1 test case (<1%) had incorrect layout
3 test cases (<1%) had stderr output
Comment 5 Eric Seidel (no email) 2009-10-23 12:04:24 PDT
Comment on attachment 41709 [details]
proposed patch

Sorry about the commit-queue trouble.  Should work fine now.
Comment 6 WebKit Commit Bot 2009-10-23 12:31:02 PDT
Comment on attachment 41709 [details]
proposed patch

Clearing flags on attachment: 41709

Committed r49988: <http://trac.webkit.org/changeset/49988>
Comment 7 WebKit Commit Bot 2009-10-23 12:31:09 PDT
All reviewed patches have been landed.  Closing bug.