Bug 30673 - [Qt] Windowless Plugins : Poor Flash performance
Summary: [Qt] Windowless Plugins : Poor Flash performance
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P4 Normal
Assignee: Nobody
URL: http://www.channel4.com/
Keywords: Qt
Depends on:
Blocks: 35962
  Show dependency treegraph
 
Reported: 2009-10-22 06:59 PDT by Tim Yamin
Modified: 2010-03-10 05:32 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Yamin 2009-10-22 06:59:10 PDT
Performance on http://www.channel4.com/ is poor with the new windowless plugin implementation -- X & WebKit use 100% CPU when you move your mouse around the Flash object, whereas this previously did not happen. Firefox & Opera do not use 100% CPU on the same page.

Tested with QtWebKit r49937, Qt 4.5.2, Flash 10.0.32.18, X server 1.6.4
Comment 1 Tor Arne Vestbø 2009-10-27 03:43:09 PDT
Thanks for your bug report.

In the future, please follow the QtWebKit bug reporting guidelines:

http://trac.webkit.org/wiki/QtWebKitContrib#ReportingBugs

In particular:

    - All bugs related to the Qt port of WebKit should have the keyword 'Qt'

You can use the following URL as a template:

    http://tinyurl.com/NewQtWebKitBug
Comment 2 Girish Ramakrishnan 2009-11-16 06:31:39 PST
Tested with r51206. I am getting around 50% CPU usage with WebKit. Around 40% for Firefox and Opera (opera's plugin wrapper i.e). So, it looks sane to me (Qt cpu usage is a little higher because of all the XSync's that we have sprinkled all :/).

In short, I cannot reproduce the problem. Can someone else test this please? Tim, can you also try on another machine?
Comment 3 Tim Yamin 2009-11-17 13:42:39 PST
Hi Girish,

On the front page, I'm getting about 30% CPU usage in the browser's process and the other 60% in X -- I'm pretty sure that all the XSync's are causing the problem; I remember that removing those from one section of the code fixed the CPU usage issue (although then it was pretty broken).

The next question is whether they can somehow be eliminated or replaced with something else -- right now, the current implementation is more or less unusable for watching Flash videos on Channel 4 (and other sites) which used to work nice and smooth but doesn't any more.

I will try on another machine to see if it works any better there -- maybe this is affecting me more with nVidia's X driver than it would with other X drivers...

Cheers,

Tim
Comment 4 Girish Ramakrishnan 2009-11-17 23:03:00 PST
(In reply to comment #3)
> Hi Girish,
> 
> On the front page, I'm getting about 30% CPU usage in the browser's process and
> the other 60% in X -- I'm pretty sure that all the XSync's are causing the
> problem; I remember that removing those from one section of the code fixed the
> CPU usage issue (although then it was pretty broken).
> 

The XSync's are required and cannot be removed until Flash is fixed.

> The next question is whether they can somehow be eliminated or replaced with
> something else -- right now, the current implementation is more or less
> unusable for watching Flash videos on Channel 4 (and other sites) which used to
> work nice and smooth but doesn't any more.
> 

Yes, from a user's perspective this is a major regression. I would like to have
some confirmation that this behavior is seen in more machines before deciding
what to do. On my machine, channel4 is perfectly usable, no 100% cpu.

Can you try disabling the nvidia driver?
Comment 5 Tim Yamin 2010-01-12 14:29:57 PST
Testing with http://www.channel4.com, I still get the same problem with X 1.7.3.902 -- it happens with both radeon and nvidia video drivers so doesn't seem to be a driver issue; aggregate CPU usage is about 60% with Arora -- X is using about 45%, Arora uses the other 15%. With Firefox it's about 25% aggregate -- X is using about 15%, Firefox uses the other 10%. I guess the underlying XSyncs in the plugin code are causing the problem here and there's not much that can be done about it, so feel free to close this as a WONTFIX.
Comment 6 Jocelyn Turcotte 2010-03-10 05:32:03 PST
Resolving as suggested by the reporter.

Please re-open if more information can be provided.