Bug 30630 - [Qt] QWebElement::removeChildren() should be QWebElement::removeAllChildren()
Summary: [Qt] QWebElement::removeChildren() should be QWebElement::removeAllChildren()
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Qt (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: Qt
Depends on:
Blocks: 29843
  Show dependency treegraph
 
Reported: 2009-10-21 07:25 PDT by Benjamin Poulain
Modified: 2009-10-27 07:23 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Poulain 2009-10-21 07:25:52 PDT
The usual prefix to remove the all the elements of a collection is "removeAll", not "remove".
E.g.
QWebDatabase::removeAllDatabases()
QUrl::removeAllQueryItems().

QWebElement::removeChildren() should be QWebElement::removeAllChildren() for consistency.
Comment 1 Kenneth Rohde Christiansen 2009-10-26 10:29:42 PDT
I'm fully OK with that.
Comment 2 Tor Arne Vestbø 2009-10-27 06:46:10 PDT
Me too
Comment 3 Kenneth Rohde Christiansen 2009-10-27 07:23:00 PDT
Landed in 50147