Bug 30596 - [Qt] Unable to load image stress test page from WebKitQt performance suite
Summary: [Qt] Unable to load image stress test page from WebKitQt performance suite
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Qt (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Major
Assignee: Nobody
URL: http://www.linuxtogo.org/~zecke/image...
Keywords: Qt
Depends on:
Blocks:
 
Reported: 2009-10-20 13:22 PDT by luying.pan
Modified: 2010-03-04 02:49 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description luying.pan 2009-10-20 13:22:50 PDT
I've tried this both from Arora and QTLauncher, the results are the same. If you observe the resident memory usage as the page loads, at the point the browser crashes, the page is 90% done, and the RSS is at over 2.5GB. I tried the same URL from GtkLauncher, and it took 200MB to render the same page.
Comment 1 Mark Rowe (bdash) 2009-10-20 13:33:12 PDT
Please summarize the bug in the summary field rather than telling a story :-)
Comment 2 Benjamin Poulain 2009-10-24 12:14:53 PDT
Opening http://www.linuxtogo.org/~zecke/image-stress-test.html with the trunk version of QtWebkit and Qt 4.6 works fine.
Comment 3 luying.pan 2009-10-26 07:14:46 PDT
The version of Qt I have is qt-everywhere-opensource-src-4.6.0-beta1
Comment 4 luying.pan 2009-10-26 07:19:20 PDT
The version of webkit I have is

Last Changed Author: vestbo@webkit.org
Last Changed Rev: 49678
Last Changed Date: 2009-10-16 09:26:57 -0400 (Fri, 16 Oct 2009)
Comment 5 Benjamin Poulain 2009-10-26 07:31:19 PDT
Could you attach a backtrace (with debug symbols) of the crash? The crash might be in a plugin, that would explain why it does not crash for me.
Comment 6 Antonio Gomes 2010-01-19 10:22:52 PST
i am running on qt 4.6.1 and webkit trunk.

page took a while to load to me, but finished at some point. no crash

* virtual mem ~500m
* res mem ~300m

worksforme ?
Comment 7 Benjamin Poulain 2010-03-04 02:49:36 PST
I agree with Antonio. I cannot reproduce the problem either, and no trace has been provided.