Bug 30568 - REGRESSION(r49806): Contextual Menu items missing
Summary: REGRESSION(r49806): Contextual Menu items missing
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh PowerPC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar, Regression
: 30571 30606 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-10-20 06:41 PDT by Kevin M. Dean
Modified: 2009-10-20 16:27 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin M. Dean 2009-10-20 06:41:22 PDT
When right-clicking links or images, I no longer see all the contextual menu options as prior to this version of the webkit nightly.

With links, I see:

Open Link, Open Link in New Window, Download Linked File, Copy Link

when I should see:

Open Link in New Window, Open Link in New Tab, Download Linked File, Download Linked File As..., Add Link to Bookmarks..., Copy Link

With images, I see:

Open image in New Window, Download Image, Copy Image

when I should see:

Open image in New Window, Open Image in New Tab, Save Image to "Downloads", Save Image As..., Add Image to iPhoto Library, Use Image as Desktop Picture, Copy Image Address, Copy Image
Comment 1 Mark Rowe (bdash) 2009-10-20 12:07:35 PDT
*** Bug 30571 has been marked as a duplicate of this bug. ***
Comment 2 Mark Rowe (bdash) 2009-10-20 12:10:13 PDT
The "Open Link in New Window” item doesn’t appear to function correctly either.
Comment 3 Mark Rowe (bdash) 2009-10-20 12:10:53 PDT
<rdar://problem/7319749>
Comment 4 Mark Rowe (bdash) 2009-10-20 12:17:17 PDT
No revisions in that range jump out as being obviously at fault.  We’ll need to bisect to determine which broke this.
Comment 5 Mark Rowe (bdash) 2009-10-20 13:53:15 PDT
Dan Bernstein!  <http://trac.webkit.org/changeset/49806>
Comment 6 mitz 2009-10-20 13:58:24 PDT
Fixed in <http://trac.webkit.org/changeset/49884>. Sorry about this accident.
Comment 7 Mark Rowe (bdash) 2009-10-20 16:27:56 PDT
*** Bug 30606 has been marked as a duplicate of this bug. ***