Bug 30517 - REGRESSION (r48064): Extra scroll bars in GarageBand Lesson Store
Summary: REGRESSION (r48064): Extra scroll bars in GarageBand Lesson Store
Status: RESOLVED DUPLICATE of bug 29167
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.6
: P1 Major
Assignee: mitz
URL:
Keywords: InRadar, NeedsReduction, Regression
Depends on:
Blocks:
 
Reported: 2009-10-19 09:27 PDT by mitz
Modified: 2009-11-09 09:56 PST (History)
3 users (show)

See Also:


Attachments
Screenshot (134.43 KB, image/png)
2009-10-19 09:27 PDT, mitz
no flags Details
Made FrameView track whether it’s allowed to have scrollbars again (6.94 KB, patch)
2009-11-05 10:32 PST, mitz
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2009-10-19 09:27:59 PDT
Created attachment 41425 [details]
Screenshot

<rdar://problem/7314421>
The GarageBand Lesson Store has aqua scroll bars in addition to the internal black vertical scroll bar.

Steps to Reproduce:
1. Open GarageBand
2. If the Lesson Store is selected in the GarageBand window’s sidebar, select a different item, quit GarageBand, and repeat from step 1.
3. In the GarageBand window, select Lesson Store on the left.

Results:
The Lesson Store has both aqua scroll bars and an internal black vertical scroll bar. See screenshot.

Regression:
This was caused by <http://trac.webkit.org/changeset/48064>, the fix for bug 28614 (which interestingly didn’t include a regression test).
Comment 1 Mark Mentovai 2009-11-04 19:58:39 PST
r48064 (bug 28614) was an aggressive version of a fix.  Bug 29167 modifies it to be more conservative.  I wonder if that patch would help this bug too.
Comment 2 mitz 2009-11-05 10:32:20 PST
Created attachment 42576 [details]
Made FrameView track whether it’s allowed to have scrollbars again
Comment 3 Mark Mentovai 2009-11-05 21:33:33 PST
Bug 29167 attachment 42627 [details] should fix this.
Comment 4 mitz 2009-11-09 09:56:28 PST

*** This bug has been marked as a duplicate of bug 29167 ***