Bug 30086 - bugzilla-tool rollout --complete-rollout raises exception with new bugzilla
Summary: bugzilla-tool rollout --complete-rollout raises exception with new bugzilla
Status: RESOLVED DUPLICATE of bug 29212
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-05 12:12 PDT by Eric Seidel (no email)
Modified: 2010-01-06 13:54 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2009-10-05 12:12:54 PDT
bugzilla-tool rollout --complete-rollout raises exception with new bugzilla

Logging in as eseidel@chromium.org...
Re-opening bug 29069
Committed r49107: <http://trac.webkit.org/changeset/49107>
Traceback (most recent call last):
  File "/Users/eseidel/Projects/WebKit/WebKitTools/Scripts/bugzilla-tool", line 902, in <module>
    main()
  File "/Users/eseidel/Projects/WebKit/WebKitTools/Scripts/bugzilla-tool", line 899, in main
    return tool.main()
  File "/Users/eseidel/Projects/WebKit/WebKitTools/Scripts/bugzilla-tool", line 894, in main
    return command_object.execute(command_options, command_args, self)
  File "/Users/eseidel/Projects/WebKit/WebKitTools/Scripts/bugzilla-tool", line 553, in execute
    self._reopen_bug_after_rollout(tool, bug_id, comment_text)
  File "/Users/eseidel/Projects/WebKit/WebKitTools/Scripts/bugzilla-tool", line 526, in _reopen_bug_after_rollout
    tool.bugs.reopen_bug(bug_id, comment_text)
  File "/Users/eseidel/Projects/WebKit/WebKitTools/Scripts/modules/bugzilla.py", line 480, in reopen_bug
    self.browser['bug_status'] = ['REOPENED']
  File "/Library/Python/2.5/site-packages/ClientForm-0.2.10-py2.5.egg/ClientForm.py", line 2897, in __setitem__
  File "/Library/Python/2.5/site-packages/ClientForm-0.2.10-py2.5.egg/ClientForm.py", line 2092, in __setattr__
  File "/Library/Python/2.5/site-packages/ClientForm-0.2.10-py2.5.egg/ClientForm.py", line 2113, in _set_value
  File "/Library/Python/2.5/site-packages/ClientForm-0.2.10-py2.5.egg/ClientForm.py", line 2136, in _single_set_value
  File "/Library/Python/2.5/site-packages/ClientForm-0.2.10-py2.5.egg/ClientForm.py", line 2121, in _get_items
ClientForm.ItemNotFoundError: insufficient items with name 'REOPENED'
Comment 1 Eric Seidel (no email) 2010-01-06 13:54:25 PST
I've fixed this as part of the patch I'm about to attach to bug 29212.

*** This bug has been marked as a duplicate of bug 29212 ***