Bug 30040 - -webkit-transform: scale() causes rendering errors for -webkit-box-reflect
Summary: -webkit-transform: scale() causes rendering errors for -webkit-box-reflect
Status: RESOLVED DUPLICATE of bug 19179
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-03 03:43 PDT by Samo Korosec
Modified: 2009-10-04 22:41 PDT (History)
1 user (show)

See Also:


Attachments
borders visible in reflections of scaled elements (2.62 KB, application/xhtml+xml)
2009-10-03 03:43 PDT, Samo Korosec
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samo Korosec 2009-10-03 03:43:32 PDT
Created attachment 40569 [details]
borders visible in reflections of scaled elements

If an element with a reflection (-webkit-box-reflect with a gradient mask) is scaled, the reflection contains what look like borders of the original DIV that go outside of the masked area. Setting border:none for the scaled elements seems to work for the horizontal (top/bottom) borders, but not for the vertical ones. Also, it seems as if the original widht of the element influences the border visibility – the regression attachment gives the (class="menu-container") elements a width of 200px which seems to work better than one of 220px or 300px. So it might be a rounding error at work?
Comment 1 mitz 2009-10-04 22:41:49 PDT

*** This bug has been marked as a duplicate of bug 19179 ***