Bug 29810 - [V8] Unsigned int return values are incorrectly treated as signed.
Summary: [V8] Unsigned int return values are incorrectly treated as signed.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-28 09:11 PDT by Dimitri Glazkov (Google)
Modified: 2009-09-28 13:24 PDT (History)
3 users (show)

See Also:


Attachments
Fixed type-conversion error in CodeGeneratorV8.pm, v1. (1.42 KB, patch)
2009-09-28 09:12 PDT, Dimitri Glazkov (Google)
abarth: review+
commit-queue: commit-queue-
Details | Formatted Diff | Diff
Add index arguments special case, v1. (1.42 KB, patch)
2009-09-28 10:53 PDT, Dimitri Glazkov (Google)
levin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitri Glazkov (Google) 2009-09-28 09:11:29 PDT
In CodeGeneratorV8.pm, "unsigned long" return value in IDL incorrectly generates "int" in C++. It should be "unsigned" instead.
Comment 1 Dimitri Glazkov (Google) 2009-09-28 09:12:47 PDT
Created attachment 40238 [details]
Fixed type-conversion error in CodeGeneratorV8.pm, v1.

 WebCore/ChangeLog                           |   13 +++++++++++++
 WebCore/bindings/scripts/CodeGeneratorV8.pm |    3 ++-
 2 files changed, 15 insertions(+), 1 deletions(-)
Comment 2 Adam Barth 2009-09-28 09:15:32 PDT
Comment on attachment 40238 [details]
Fixed type-conversion error in CodeGeneratorV8.pm, v1.

Nice!  I presume the test mentioned already exists.
Comment 3 Dimitri Glazkov (Google) 2009-09-28 09:21:56 PDT
Yep. tkent wrote it :)
Comment 4 Dimitri Glazkov (Google) 2009-09-28 09:29:40 PDT
Landed as http://trac.webkit.org/changeset/48817.
Comment 5 Dimitri Glazkov (Google) 2009-09-28 10:48:10 PDT
Oops. I maked bugs. Fix coming up.
Comment 6 Dimitri Glazkov (Google) 2009-09-28 10:53:24 PDT
Created attachment 40245 [details]
Add index arguments special case, v1.

 WebCore/ChangeLog                           |   13 +++++++++++++
 WebCore/bindings/scripts/CodeGeneratorV8.pm |    5 +++++
 2 files changed, 18 insertions(+), 0 deletions(-)
Comment 7 Dimitri Glazkov (Google) 2009-09-28 10:53:52 PDT
Fix uploaded. Sorry for the troubles.
Comment 8 WebKit Commit Bot 2009-09-28 10:54:18 PDT
Comment on attachment 40238 [details]
Fixed type-conversion error in CodeGeneratorV8.pm, v1.

Rejecting patch 40238 from commit-queue.

Patch https://bugs.webkit.org/attachment.cgi?id=40238 from bug 29810 failed to download and apply.
Comment 9 Dimitri Glazkov (Google) 2009-09-28 10:57:52 PDT
Fix landed as http://trac.webkit.org/changeset/48820.
Comment 10 Eric Seidel (no email) 2009-09-28 13:24:00 PDT
patching file WebCore/bindings/scripts/CodeGeneratorV8.pm
Hunk #1 FAILED at 1711.
1 out of 1 hunk FAILED -- saving rejects to file WebCore/bindings/scripts/CodeGeneratorV8.pm.rej

Was the cause of the rejection.