Bug 29755 - ASSERTION FAILED: !repaintContainer || repaintContainer == this
Summary: ASSERTION FAILED: !repaintContainer || repaintContainer == this
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords: InRadar
: 28898 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-09-25 17:28 PDT by Simon Fraser (smfr)
Modified: 2009-09-30 11:02 PDT (History)
0 users

See Also:


Attachments
Patch (12.67 KB, patch)
2009-09-25 17:46 PDT, Simon Fraser (smfr)
no flags Details | Formatted Diff | Diff
Better fix (10.32 KB, patch)
2009-09-29 17:04 PDT, Simon Fraser (smfr)
mitz: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2009-09-25 17:28:00 PDT
Certain configurations of hardware accelerated content hit this assertion in RenderView. It indicates that RenderObject::container() returned an object above repaintContainer in the hierarchy.

It's triggered by compositing layers made for opacity fades in between position: absolute layers.
Comment 1 Simon Fraser (smfr) 2009-09-25 17:28:25 PDT
<rdar://problem/7032254>
Comment 2 Simon Fraser (smfr) 2009-09-25 17:46:11 PDT
Created attachment 40155 [details]
Patch
Comment 3 Simon Fraser (smfr) 2009-09-28 09:14:46 PDT
http://trac.webkit.org/changeset/48816
Comment 4 Simon Fraser (smfr) 2009-09-29 14:26:42 PDT
This fix doesn't get all cases.
Comment 5 Simon Fraser (smfr) 2009-09-29 16:59:51 PDT
*** Bug 28898 has been marked as a duplicate of this bug. ***
Comment 6 Simon Fraser (smfr) 2009-09-29 17:04:27 PDT
Created attachment 40335 [details]
Better fix
Comment 7 Eric Seidel (no email) 2009-09-29 18:26:08 PDT
Comment on attachment 40155 [details]
Patch

Obsoleting this patch that looks like it was already landed.
Comment 8 Simon Fraser (smfr) 2009-09-30 11:02:01 PDT
http://trac.webkit.org/changeset/48932