Bug 29276 - REGRESSION(r48334): WebKit crashes on file select by drag
Summary: REGRESSION(r48334): WebKit crashes on file select by drag
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P1 Major
Assignee: Sam Weinig
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-15 11:52 PDT by Ain Tohvri
Modified: 2009-09-18 22:44 PDT (History)
4 users (show)

See Also:


Attachments
Crash log (37.90 KB, text/plain)
2009-09-15 11:52 PDT, Ain Tohvri
no flags Details
patch (1.80 KB, patch)
2009-09-17 21:19 PDT, Sam Weinig
adele: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ain Tohvri 2009-09-15 11:52:58 PDT
Created attachment 39608 [details]
Crash log

Steps to reproduce:

1. Sign in to WebKit Bugzilla
2. Go to create a new bug report
3. Click 'Add an attachment'
4. Drag a file to file input to select a file
5. WebKit crashes
Comment 1 Mark Rowe (bdash) 2009-09-15 12:15:37 PDT
This must be a recent regression.  I dragged some patches to the file button yesterday with a build from Friday without hitting a crash.
Comment 2 Mark Rowe (bdash) 2009-09-15 21:49:16 PDT
This was caused by <http://trac.webkit.org/changeset/48334>.
Comment 3 Sam Weinig 2009-09-17 21:19:49 PDT
Created attachment 39747 [details]
patch
Comment 4 Sam Weinig 2009-09-17 22:22:06 PDT
This should have a test.  I will work on one tomorrow.  Patch landed in r48500.
Comment 5 Eric Seidel (no email) 2009-09-17 22:43:12 PDT
Comment on attachment 39747 [details]
patch

Can't we test this?  I'm surprised this doesn't have a test given eventSender.beginDragWithFiles()
Comment 6 Eric Seidel (no email) 2009-09-17 22:43:32 PDT
Ah, nm, now I see your comment above.
Comment 7 Sam Weinig 2009-09-18 11:02:39 PDT
Test and extended fix landed in r48515.
Comment 8 Ain Tohvri 2009-09-18 22:44:36 PDT
Yup, works for me as well in the latest r48518. Great job!