Bug 29189 - Incorrect containing block for blocks that have an inline parent
: Incorrect containing block for blocks that have an inline parent
Status: RESOLVED WORKSFORME
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering
: 528+ (Nightly build)
: PC Mac OS X 10.5
: P2 Normal
Assigned To: Nobody
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-11 09:28 PDT by Boris Zbarsky
Modified: 2013-11-19 10:21 PST (History)
5 users (show)

See Also:


Attachments
Testcase showing height issue (183 bytes, text/html)
2009-09-11 09:28 PDT, Boris Zbarsky
no flags Details
Testcase showing margin issue (304 bytes, text/html)
2009-09-11 09:29 PDT, Boris Zbarsky
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Boris Zbarsky 2009-09-11 09:28:56 PDT
Created attachment 39443 [details]
Testcase showing height issue

BUILD: Today's webkit nightly

STEPS TO REPRODUCE:  Load attached testcases

EXPECTED RESULTS:
First testcase: Block with black border has height 100px
Second testcase: Block with black border has a left margin of 0 and a right margin of 10px

ACTUAL RESULTS:
First testcase: Block with black border has height 0
Second testcase: Block with black border has a left margin of 10px and a right margin of 0

Both are most likely due to using the wrong thing as the containing block.
Comment 1 Boris Zbarsky 2009-09-11 09:29:17 PDT
Created attachment 39444 [details]
Testcase showing margin issue
Comment 2 Simon Fraser (smfr) 2011-01-13 08:53:08 PST
*** Bug 52373 has been marked as a duplicate of this bug. ***
Comment 3 Robert Hogan 2013-11-18 23:05:27 PST
These both pass now.
Comment 4 Alexey Proskuryakov 2013-11-19 10:21:14 PST
Do we need to land a test case?