You need to
before you can comment on or make changes to this bug.
For the Qt port we would like to differentiate the return type of platformWidget and platformWindow, so that we can typedef that to something else.
In particular we would like to use platformWindow to return a QWebPageClient.
Since the platformWindow is per page, I would additionally like to rename it to platformChromeClient or platformPageClient. Any objections to such a change?
You should talk to Hyatt about this change. He added the PlatformWindow stuff, I believe.
Created an attachment (id=39712) [details]
Make PlatformWindow return something else than PlatformWidget
(From update of attachment 39712 [details])
Eric, does this require any changes in Chromium? How can we synchronize the landing with the changes needed in Chromium?
Adding Darin (fishd).
This requires a small renaming change in the Chromium repository. Fortunately, we always return NULL for the platformWidget. So, the fixup on our end should just be about renaming the ChromeClient method.
(In reply to comment #7)
> This requires a small renaming change in the Chromium repository. Fortunately,
> we always return NULL for the platformWidget. So, the fixup on our end should
> just be about renaming the ChromeClient method.
That said, is it OK with you that I commit this right away?
We'll be able to cope. Thanks!
Thansk! Landed in 48511